Getting Started

Help >

Getting Started with Spitronics Devices

About the product.

Spitronics products are developed for the DIY market and are mostly sold through dealers and handy customers abroad. This distribution channel provides the client with a more cost effective product as the company's' overheads are kept to a minimum. Spitronics rather makes use of an extensive network of dealers that professionally specialize in this type of industry. The Spitronics devices are not plug & play devices but must be customized by a dealer for specific applications. These products are very versatile and can be adapted to most engines and transmissions. The dealer is responsible for after sale services and is a third party entity. Spitronics have preferred accredited dealers in various areas however such dealers are entities' on their own and therefore Spitronics cannot control services rendered or customer grievances concerning such services or poor service by these service providers. Spitronics are not affiliated to these concerns in any way legally or professionally. So make sure about the dealers' service and capabilities before you support or purchase from them. Spitronics is a separate entity responsible for the manufacturing of such products, thus cannot be responsible or associated for any unsatisfactory services provided by outsourced agents/ dealers.

Please read our terms and conditions found on our website. All the information, software and manuals are freeware on our website www.spitronics.com

Block Diagram of Product interfacing

How does Spitronics Products Work

Each Spitronics product is Micro based which requires a firmware program to initialize the hardware, and tuning Maps that adjust parameters and graphs for the engine or transmission. The Maps require tuning software so that the tuner can adjust fuel and timing for that application. The product also needs to be activated before it will operate.

1. The firmware will initialize the hardware to work on a specific engine or transmission. This firmware is fixed code and is pre-loaded into the product with the USB Debug Adapter. It is optional for an end user because he will use it only once. The dealer has the option to customize standard hardware for all different applications with this programmer. The firmware files is freeware on our website and has the extension of .HEX. This process is illustrated in the left laptop configuration.

2. Spitronics developed an internet activation system to allow dealers abroad to carry stock at a reduced price. Then when the dealer sell to a customer he will activate the unit in a specific hardware class according to the firmware and application of the customer. He will then do a payment for the rest of the amount. He will load the correct firmware and startup Map for the customer and guide him to the correct drawings and settings. He will test the unit on a simulator and verify that everything is in order as to assist the customer. This feature makes the product counter ready without the delay of ordering the product on demand.

3. The tuning software will allow the tuner to adjust his engine or transmission to his requirement. This could be performance, economy, automatic or tiptronic etc. This tuning data is saved in the product and also in a file called a data Map with the extension .Galaxy.

What you need to get started.

1. The product hardware and accessories for the specific application. This will be the ECU / TCU, control modules such as idle control and Coil Igniters, harnesses, MAP sensors etc. for that specific application. The product is sold in different classes and prices according to features and outputs used. There is a chart on the website indicating the different classes. Information on what you need can be found under products and there is selections charts. Or you may ask a dealer in your area of send a mail to info@spitronics.com

2. The USB / UART communication cable to connect the device on to a laptop for tuning purposes. This cable is sold separate as you only need one for tuning all our products. Also the electronics is put in the cable which means the product becomes cheaper as each does not require those components. This product has drivers that needs to be installed before it will operate.

3. The tuning software to interface with the products. The software is only Windows based and works on all versions. You need a Laptop or Tablet for this.

4. A Startup map which helps with the setup of the specific engine. As each engine differs in minor changes these MAP's still require a bit of refining. It is a data file that is saved on the hard disk and differs for each type of engine. If you don't get a specific map for you engine you may adapt any map to suit your engine.

5. The manuals for explaining wiring and tuning. These manuals became bulky with all the information but once you browse through them you will get to your info quickly. They are available on the web and is updated from time to time.

Optional requirements.

1. The firmware programmer. This USB Debug Adapter lets you customize the product yourself for any engine or transmission or custom task that firmware was developed. Firmware is free and placed on the website. You can browse there to see if you application is covered. The programmer is also used to download the latest updates for your application. Then new features may be added for your convenience. We always recommend buying one programmer to distant customers. There is also test firmware to help in fault finding.

2. The simulator helps dealers to find faults on customers units. It is recommended for the dealer that likes to carry stock and help customers over the counter. The latest Simulator2 works on all our products with the exception of different connecting harnesses.

Useful links and direction of info on the website.

The USB / UART communication cable.

·

·

·

· http://www.spitronics.co.za/downloads/USB%20Drivers/Spitronics_USB_Drivers.rar

The Ver 3 Galaxy Tuning software.

·

·

·

·

· http://www.spitronics.co.za/downloads/Tuning%20Software/Galaxy%20Ver%203/Galaxy%20Installer%20(PARTIAL).exe

The Galaxy Install Guide

·

·

·

·

· http://www.spitronics.co.za/downloads/Tuning%20Software/Galaxy%20Ver%203/Galaxy%20Install%20Guide.pdf

The Galaxy Manual

·

·

·

· http://www.spitronics.co.za/downloads/Manuals/Galaxy%20Mercury2%20Neptune2%20Pluto%20Manual%2030_09_2015%20(under%20construction).rar

The Drawings Manual

·

·

·

· http://www.spitronics.co.za/downloads/Manuals/Drawings%20Pluto%20Mercury2%20Neptune2%2010_03_2016.rar

Optional links and direction of info on the website.

The Firmware Programmer (USB Debug Adapter)

·

·

·

· http://www.spitronics.co.za/downloads/Firmware%20Programmer/mcu_ide.exe

Installation of Software, Drivers and Manual

Manuals

Galaxy Manual

Click with the mouse on the blue Galaxy Manual link under the Useful Links topic. The browser should download the Manual in the downloads folder. Sometimes the antivirus programs will block the content of HTML files or ask you permission if you want the content. Say yes to keep content. The file is compressed with WinRAR which is freeware software. Un-compress the file. If you open the file and the data is not complete, close it and right click on the icon and give it permissions to open the data. Again this is a windows virus protection feature. Then open the file and it should look like the picture at the bottom.

Drawings Manual

Click with the mouse on the blue Drawings Manual link under the Useful Links topic. The browser should download the Manual in the downloads folder. Sometimes the antivirus programs will block the content of HTML files or ask you permission if you want the content. Say yes to keep content. The file is compressed with WinRAR which is freeware software. Un-compress the file. If you open the file and the data is not complete, close it and right click on the icon and give it permissions to open the data. Again this is a windows virus protection feature. Then open the file and it should look like the picture at the bottom.

USB Drivers

Click with the mouse on the blue The USB / UART communication cable link under the Useful Links topic. The browser should download the drivers in the downloads folder. The drivers file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a folder created as below.

Go into the folder and you should see the following.

If you have a 64bit computer then run the file called

For 32bit computer run the file called

After you installed the driver plug the USB /UART cable into the computer and the cable will be activated. In the device manager you should see the block below in com ports. This means the drivers are installed correctly.

Tuning Software

Click with the mouse on the blue Ver 3 Galaxy Tuning software link under the Useful Links topic. The browser should download the file in the downloads folder. The file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a file created as below.

Run the file and Galaxy will be installed on the computer.

Click with the mouse on the blue The Galaxy Install Guide link under the Useful Links topic. The browser should download the file in the downloads folder. The file is a PDF file that is a guide on how to install the Galaxy properly.

Firmware Programmer

In the manual is a complete description of how to install and operate the Firmware Programmer. Again very important is the Precautions. Read them carefully. Never press the Erase All Code Space button. It will render the product useless and it will have to be returned to the factory. Below is a screen shot of where you can find it in the Galaxy Manual.

Connecting a Product to Galaxy for the first time.

By now you should be familiar with the product and information around it. The chapters you should read before attempting to start is the Safety Precautions first making sure you prevented the obvious faults that could damage the unit or components of the engine.

Secondly you should follow the Startup Procedure step by step as it is explained in the manual. Do not attempt to take shortcuts and try to start. If you missed some points in the setup, the ECU or engine components could be damaged. Each Product differs and has its own unique way in the Startup Procedure. Each point is numbered and you can reference this number to the dealer to ask him for advice. If the number does not function correctly do not go further till it is solved. Failing to do so may damage the unit and inflict repair costs for your account.

Below is a screenshot where you can find it in the manual.

Copyright © 2013. All rights reserved.


Precautions

Help >

Safety Precautions

The guidelines in this manual have been clearly laid out and are specifically included for your benefit assistance to ensure proper product operation and installation first time.

Failure to install the product correctly could cause permanent damage to the ECU and/or other equipment. Please note: such failures are solely the responsibility of the installer and under no circumstances does Spitronics take responsibility on behalf of the installer for damages or loss incurred.

Make sure you have read the Terms and Conditions in this manual or on the website, www.spitronics.co.za before you install this product. By installing the product you automatically agree to these conditions. No guarantees are given by Spitronics. All equipment is tested before it leaves the factory. We do not accept liability for malfunctioning of the equipment, or to injury that may result from installation or the use of the equipment. We do not accept liability for incurred costs, traveling or transportation of equipment cost or/and, parts or vehicle recovery cost, due to failures of any equipment of any kind. (SEE TERMS AND CONDITIONS).

Please read the instructions and drawings, make sure you understand before you begin.

2.1 Operator Safety

  • Use only proper tools and products suited to professional auto installers. Substandard products and installation procedures may cause failures to the equipment, and/or customer break downs.
  • Use correct thickness of wire to carry the entire current requirement for that circuit. Too thinner wires will heat up and may start a fire causing injury.
  • Use fuses to protect each circuit separately. Joint circuits require large fuses which may heat and melt lesser circuits causing fires.
  • Solder joints, and cover it with shrink sleeve to prevent loose connections which may cause fires. Space solder-joints so that they do not sit next to each other in the harness, thus minimizing the chance of a short circuiting.

(See the individual Safety Precautions for each product.)


Mercury2

Help > Precautions >

Mercury2_Safety Ver 3.5

Mercury2 Safety Precautions

Connecting:

· Never connect a Mercury2 on other harnesses that have the same connecters.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connectors P2, P3 and P5 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get there power from the Saturn power relays. This relay will only switch on after the ECU has selected the logicical level for the driver.Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless it is shown on a drawing. Check the current rating or the outputs in the Specifications.

· Test the coil resistance to see which coil type you are using and if it is still functional. This is important to program the correct parameters.( See Coil Selection) If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance are very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU harness and damage it.

Power:

· Ensure that fuses are the minimum value required value to hold the current. Too larger fuses will not blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through then melting the harness. It will also bring all the engine interference in the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This will cause voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer:

· If you have a firmware programmer, ensure you only load firmware with the starting name Mercury2. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2, P3 and P5 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. See the programmer manual for correct operation.

Interference:

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

· Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
The wiring is critical for reliable operation of the ECU. (The following points will help to ensure that the wiring is reliable):

· Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. This applies to both the ECU earth wire and the ignition system earth wires.

· Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

· Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

· Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity, gently touch the side of the terminal only.

· Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

· Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


Pluto2

Help > Precautions >

Pluto2_Safety Ver 3.5

Pluto Safety Precautions

Connecting

· Never connect a Pluto on other harnesses that have the same connecters.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connector P2 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get there power from the Saturn power relays. This relay will only switch on after the ECU has selected the logic level for the driver.

· Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· Ensure that the Trigger Output Level of the coils is correctly set for the coils you are using, before you connect the 10 Way connecter. Having this wrong may damage the ECU and coil permanently.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless shown on a drawing. Check the current rating in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. ( See Coil Selection) If you are not sure, take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input must not be connected to coil negative. The high voltage spikes on coil negative and will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU damaging it.

Power

· Ensure that fuses are the minimum required value to hold the current. Too larger fuses will blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse, as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through and so melting the harness. It will also bring all the engine interference into the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This causes voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer

· If you have a firmware programmer, ensure you only load firmware with the starting name Pluto2. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. (See the programmer manual for correct operation.)

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. (See the drawings for correct connections)

· Connect screen input wires as close to the sensor wires as possible to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
 The wiring is critical for reliable operation of the ECU. (The following points will help to ensure that the wiring is reliable):

· Earth wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

· Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

· Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

· Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity, gently touch the side of the terminal only.

· Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. If they are too big they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

· Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


Saturn

Help > Precautions >

Saturn_Safety Ver 3.5

Saturn Safety Precautions

Connecting

· Never connect a Saturn on other harnesses that have the same connecters.

· Connect the ECUs' earth strap and the harness's Earth wires to a proper earth on the cars' body.

· Leave the output connector P2, P3 and P4 disconnected when you switch the ECU on for the first time.

· Test the installation before connecting the ECU. (This will prevent damage due to faulty wiring.)

· Make sure relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get power from the Saturn power relays. This relay will only switch on after the ECU has selected the logic level for the driver. Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· Ensure that the Trigger Output Level of the coils are correctly set for the coils you are using, before you connect the 10 Way connecter. If this is incorrect you may damage the ECU and coil permanently.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put Cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECUs' outputs directly to solenoids or fuel pumps unless shown on a drawing. Check the current rating in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to ensure correct parameter programming. (See Coil Selection.) If you are not sure take, it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors needed and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU damaging it.

Power

· Ensure that fuses are the minimum value required to hold the current. Too larger fuses will blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops and will cause leaner mixtures.

· Connect the injectors to its own relay, if mechanical relays are used, as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through causing the harnesses to melt. It will also bring all the engine interference into the ECU.

· Ensure a proper earth between battery negative and chassis, also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while the engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness. This will cause voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly. This may damage sensors or the ECU.

Programmer

· If you have a firmware programmer, ensure you only load firmware with the starting name Saturn. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2, P3 and P4 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. (See the programmer manual for correct operation.)

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. (See the drawings for correct connections.)

· Connect screen input wires as close to the sensor wires as possible to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability

The wiring is critical for reliable operation of the ECU. (The following points will help to ensure that the wiring is reliable):

· Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

· Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery, via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

· Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

· Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity, gently touch the side of the terminal only.

· Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

· Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement do not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


GP Output Priority

Help > Hardware Isralation >

GP Output priority features

This chapter assists in understanding specific firmware programs how the general purpose outputs are handled. Sometimes a single output will share 2 or 3 features. Then this document will explain which one takes priority over the other.

See the sub folders if there is an article on your application.


Mercury2 General 4 Cyl

Help > Hardware Isralation > GP Output Priority >


Mercury2 General 6 Cyl

Help > Hardware Isralation > GP Output Priority >


Mercury2 General 8 Cyl

Help > Hardware Isralation > GP Output Priority >


Mercury2 Lexus V8 1UZ-FE vvti

Help > Hardware Isralation > GP Output Priority >


Mercury2 Lexus V12 1GZ- vvti

Help > Hardware Isralation > GP Output Priority >


Mercury2 Mazda 2 Rotor

Help > Hardware Isralation > GP Output Priority >


Harness Level Discrption

Help > Hardware Isralation >

Harness Level description

To make ordering easier we've categorized harness's in different groups. The price increases as levels increase, however the installer saves time on his side.

Level 1

Basic harness. This harness comes with a connector and the wires that go into them and are already predetermined lengths. The wires are marked and the colors are found on the drawings. Each installer will customize these harnesses in the car to his specifications. He will add relays and fuse box wiring himself and supply all the power wires to the components like coils, injectors, fuel pump etc.

Advantages

· Cost effective option

· Easy to customization for the car

Disadvantages

· No fuse boxes included

· No power wires included

· Lengthily installation time

Level 2

Premade complete loom untidy. This harness comes with all the connectors and the wires in one loom with already predetermined lengths. The wires are marked and the colors are found on the drawings. Relays and fuses are wired into the loom which will save installation time. The loom is not tidied up yet to leave the installer the option to reroute GP output wires to different locations. The heat shrink on the connectors are supplied loosely to be tidied afterwards. There is also a roll of cloth tape provided to enable the installer to cover his wires neatly.

Advantages

· Easy preparation for a customer

· Easy customization for the car

· Time saving during installation

· Eliminates errors in wiring

Disadvantages

· Price is increased

· Finishing work to tidy harness still needs to be carried out

Level 3

Premade complete loom tidied. This harness is the same as level 2 but it is tidied up for the customer. The dealer prepares the GP outputs and marks them. The heat shrink is shrunk and the loom is neatly wrapped on the open sides with cloth tape. All the customer needs to do is solder and neaten up his connectors.

Advantages

· Easy installation

· Time saved during installation

· Eliminates errors in wiring

Disadvantages

· Price is increased

· Connectors need to be soldered on

Level 4

Plug & Play loom. This harness is the same as level 3, but the connectors have been soldered already. Now this may be new connectors or the ones supplied from that engine. Not all looms will come like this as there are a big variation in connector types.

Advantages

· Easy installation

· Time saving during installation

· Eliminate errors in wiring

Disadvantages

· Price is increased


ECU Settings

Help > Galaxy Sotware Ver 3.5 >

P3_Settings_0 Ver 3.5

Settings

This block is where all the setup values for the ECU is situated so that the tuner can set his engine up.

See the sub folders for explanations.


Engine Settings

Help > Galaxy Sotware Ver 3.5 > ECU Settings >

P3_M1_0 Ver 3.5

Engine Settings

(See sub folders for explanations.)


Map Information

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Engine Settings >

P3_M1_A Ver 3.5

MAP Information

The Map information screen, Name Model and Engine, contains info for the ECUs' application for a specific vehicle. This helps the tuner to recognize previous work and tuning data. It is saved in the ECU and also in' PC maps'. It does not affect any tuning on the engine.

Map Number

The firmware consists of 2 maps for different fuel setups or tuning algorithms. This is only an indication, the map cannot be forced on this page. This block is updated when the ECU is switched on. If no selection switch is connected the ECU will default to Map 1. Note: The maps cannot be changed during engine running. The power of the ECU has to be cycled for the new Map to be loaded.

Dual Map Selection

The map selection is determined by the Dual Map Selection switch. Note that this block varies depending on the product used. For Mercury2 there are no specific input dedicated to the Map switch. An input that is not used can be selected for this feature. If all the inputs are utilized then the dual map cannot be used. With Mercury2 you may select between Cam 2, Fuel Pressure input and Altitude input to be used for the Map selection switch. Pluto2 and Saturn has a dedicated input, this whole block will be blanked out. This switch is read at startup and the map cannot be changed during running. The ECUs' power has to be switched off first to effect the selection, then only will the switch determine on which map the ECU will start. If the driver wants to change maps, he simply toggles the switch on the dashboard and switches the ignition off and on again. If it started on MAP 2, the Map No (number) will indicate 2 when the software is restarted. Press the upload button [image] to read the new map information. (See the wiring diagrams for info on the different connections.)

NB!! Note that the fuel sensor input requires a 1K pull-up resistor to 5V and not 12 Volt. This may damage the processor.

Tuning Mode

This feature allows the tuner to select variations of tuning, according to his skills. The firmware will enable more features as the levels progress and hide features on lower levels so that confusion for beginners is kept at a minimum.

Novice

This level is set up as the first generation of Spitronics ECUs'. There are however, new features which is explained further in the manual. This mode is used for graph tuning and developed by Spitronics. It is easier for road tune when Dyno's are not present.

Moderate

This tuning type is more for tuners with Dyno facilities. In this level the matrix tuning is present as well as the graph method for fuel and timing. There is a selection for MAP or TPS tuning versus RPM. Included is a mixture between the selections especially included to make it possible for racing engines with poor vacuum, but with turbo chargers where MAP pressure needs to be compensated. The tuner can select his desired option. Note: The graph and matrix data uses its own memory space and both types could be tuned without losing the data on selection changes. This allows the tuner to select between the options and chose the best option for his application.

Expert

This mode is to assist the tuner to tune racing engines and different fuels where more refined parameters are required. Here parameters like Start Prime Pulse, Start enrichment, and the 2 accelerator pump enrichment values are tuned on a graph versus temperature. This is very useful for methanol cars also in extreme cold conditions when fuel does not want to ignite easy.

Save Setup Data

This is a very useful feature to help customers to change tuning maps without altering there setup data. It may be that 2 applications for the same engines are wired differently but still run correctly due to setup changes. For example the crank trigger may be wired positive or negative and then the rising or falling edge needs to be changed. Now if you load one map on another engine it would possibly not start or run erratic. If you set this Save Setup data off, then the other map could be loaded and the whole setup block will be ignored. Just the tuning data and graphs will be loaded.

(A useful tip) Leave this setting off, any changes on the setup while the ECU is connected is saved as normal. This feature is permanently saved in the ECU and can only be changed on the screen when the ECU is connected.


Engine Configuration

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Engine Settings >

P3_M1_B Ver 3.5

Engine Configuration

Cylinders

Most ECU firmware will lock the selection for a specific number of cylinders. Other firmware like the standard unit will open this dropdown menu for the tuner to decide which engine is required.

Map Teeth (Gear Type Trigger Only)

This setting is used to synchronize the crank angle degrees where the manifold vacuum is sampled. This is very useful for engines with individual throttle bodies that has poor vacuum signal due to a common vacuum rail. This setting can be adjusted up to 180° of engine rotation after TDC. If it is a 36-1 gear (As in this example), then 9 teeth will result in 90° after TDC. Start at 90° after TDC and adjust the teeth more or less at idling till the best vacuum signal is achieved. Start with the gear teeth divide by 4. For a 60-2, it will be 15. On throttle bodies you only connect one cylinder to the Map sensor. It must be cylinder 1 or the one that shares the same TDC degrees with it. Do not use a common vacuum rail. Set the setting as shown below.

Map sensor

Spitronics have a 4 Map Sensors selection to choose from. 1.1 Bar, 2.5 Bar, 3.0 Bar, 4.0 Bar and a Custom sensor option. Select the one that is supplied with the ECU. The most popular one is 2.5 Bar. If you use an engine MAP sensor that is not standard with the 4 selection, you may choose Custom and calibrate it yourselves. If you need to use a custom OEM sensor select the following.

Then go to active sensors and click on the calibrate button at the left of the MAP sensor checkbox. Then a calibrate panel will appear.

Now adjust the offset value till the vacuum bar reads the atmospheric pressure of you location. If you are not sure about the pressure check on Google what is the altitude and pressure at your region. Remember temperature effects barometric pressure so on a warm or cold day it may need to change slightly. Press OK and save the map afterwards.

Map Range

This setting selects the manifold pressure range that the engine is using. The ECU allows the user to use a turbo sensor and uses it for normal aspirated applications. If your engine is 'normal aspirated', select 1.1 Bar. If it has a turbo, choose a value of 0.1 Bar higher that your max boost value. Remember that the boost is added to 1 Bar atmospheric pressure. For example the engine is required to run at 0.8 Bar boost, select 1.9 Bar. This means at sea level you can run 0.8 Bar boost without running the tuning pressure off the scale. Making the scale large will reduce valuable tuning space on the graphs or matix.

RPM Range

This setting is used to adjust the ranges of the RPM tuning graphs or matrix. Set it to a value of 500 RPM above the engine max RPM. If you use a higher value you will reduce valuable tuning space.

Two Stroke

This Setting will select 2 or 4 stroke to correct the injector duty % indication bar. If it is on 4 stroke the injector time is calculated over 2 RPM's while on 2 stroke the injector time is calculated over 1 RPM. For example 10 milliseconds on 4 stoke means that the injector will inject 5 milliseconds each RPM to make up 10 milliseconds. While on 2 stroke 10 milliseconds will inject the full 10 milliseconds each RPM. If you have an engine that does not rev high and the injectors is too small you may put it on 2 stroke to double the injector time. Note: However, the injectors' duty % during tuning must not go over 100% as this will occur at a lower RPM. 85% Max is a recommended maximum duty cycle as the injector may stay open after that.

Rotary Engine

This block is checked when rotary firmware is loaded into the ECU. It is an indication only for Rotary Firmware.

Engine Shutdown

This setting will select how the engine is shut down. Fuel first means that the ECU will run normally but stop injecting fuel when the key is turned off. This ensures the spark burns all the unwanted fuel from the cylinder. This is handy for rotaries where the injectors are far from the intake valve. It may sound as if the engine keeps going for a moment after the key is switched off. Fuel & Spark cuts both immediately when the key is turned off. There may be unburned fuel on the cylinder but the engine dies immediately. Note: This feature is only available with Mercury2.


General Purpose Outputs

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Engine Settings >

P3_M1_C Ver 3.5

General Purpose Outputs

Output selection

Version 3.5 can handle up to 10 General Purpose (GP) outputs to configure for several different functions. These outputs can be configured to use the analogue signals and switch relays on or off when certain limits are reached. Due to the number of GP outputs, this block was developed to be generic. That means there is a dropdown menu to choose which one is adjusted by the tuner. Not all firmware has the ability for 10 GP outputs so the number of selections may be limited. It also depends on which features are activated in the ECU. Note: The operating current and requirements of each product in the electrical drawings are supplied to ensure care is given and preventing the ECU from been damaged.

If an output is available the software will show the location of the driver that is used with this GP output.

Should an output not be available the driver and type selections will be blank.

Selections

The tuner has a number of selections to use. Use the side slider bar to display the others. Here we grouped them together for explanation.

Not used - this saves processor time

RPM - RPM/min 100rpm increments

Vacuum - pressure 0.1 Bar increments

TPS - percentage at 1% increments

Water temperature - degrees at 1°C increments

Air temperature - degrees at 1°C increments

POT value - percentage at 1% increments

Battery voltage - voltage 0.1volt increments

Altitude - pressure 0.01 Bar increments

Fuel pressure - pressure 0.1 Bar increments

Lambda - percentage at 1% increments

Timing - degrees at 1° increments

Injector - fuel at 0.1milli second increments

The GP outputs can be used in different ways.

First we do water temperature as it operates in a unique way on all the GP outputs. In this example we will setup the water temperature to operate the electrical cooling fans.

Now the water output will come on when the temperature goes above the Max setting at 98 degrees and will stay on until below the Min. setting at 92 degrees. This will give the fan a dead band of 6 degrees before switching off. Note: Here a Positive driver is used so it will output 12 volt onto a relay solenoid side and earth on the other side.

All other types.

We want to use a GP output to switch on a shift light. The light must come on at 5000 RPM and switch off at 7000 RPM.

Note that the GP limits can only be set greater than or smaller than. This is to prevent shuddering. 'Shuddering' is due to a small dead band. This means if the light must come on or off on the rising limits, you may need to slightly change the value. In this example on rising RPM's the output will come on at 4000 RPM and off on 7000 RPM and on falling RPM's it will come on at 6800 RPM and off on 4800 RPM. So the output is on between the limits and off outside the limits.

If we swop the Min and Max settings around like below it will change the logic to Off between the limits and On outside the limits.

V-Tech

There is one GP output No2 that has the added V-Tech TPS limit added to the RPM setting.

In this method the output will switch on between the limits only if the TPS value is above 40%.

Note! If you don't use these outputs, select Not Used so that valuable processor time can be saved.

Pulses/RPM

This feature is used for Rev counter calibration. You can adjust the number of pulses per revolution for the rev counter output. This is handy for engine conversions. A value of 1 to 60 pulses can be achieved with this function. On some engines you may enter 61 which will then divert the trigger signal on the RPM output. This is handy if the standard ECU is still live and doing other functions in the car.( See the electrical connections in the drawings to achieve this).

These Auxiliary Values are used in certain firmware to achieve certain functions.( See the specific instructions for that engine type.)


Timing Settings

(See Sub folders for explanations.)


Timing Configuration

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Timing Settings >

P3_M2_A Ver 3.5

Timing Configuration

Maximum trailing

This setting is for rotary engines only and prevents the trailing degrees from being adjusted to far from the leading plugs.

Maximum Timing

This setting is the maximum combined timing allowed in degrees by all the timing maps combined. If the graphs are tuned for more degrees it will be limited by this value.

Minimum coil time

This setting is the minimum charge time which the tuner can select. The ECU will vary the charge time automatically according to vacuum load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.0 to 2.5 milliseconds for coils of around 0.7 ohms, however some new coils have lower resistance and may need shorter times. Normally the driver will heat up and may be damaged if it runs too hot. Always start with a min value if you are not sure.

Maximum coil time

This setting is the minimum charge time which the tuner can select. The ECU will vary the charge time automatically according to vacuum load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.5 to 3.5 milliseconds for coils of around 0.7 ohms but some new coils have a lower resistance and may need shorter times. Normally the driver will heat up and may be damaged if it runs too hot. Always start with a min value if you are not sure. During cold starting this value is used till the engine reaches 60°C. Thereafter spark control will commence.

Vacuum Timing Split

This value sets the RPM split between the Low & High Vacuum Timing maps. This value is selected about 500 to 1000 RPM's above idling.

Altitude comp.

This value sets the timing advance ratio for every 1000 meter above sea level. A value of 3 means that the timing will be advanced by 6 degrees at 2000 meter above sea level. If you tune the vehicle at a higher altitude make sure this value is set. Then when the driver descend to lower altitude the ECU will retard the timing automatically.


Timing Calculation

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Timing Settings >

P3_M2_B Ver 3.5

Timing Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual.

Graph MAP

This is for standard engines with a good vacuum signal and allow for easy tuning in the street.

Graph MAP+TPS

This is for standard engines with a poor vacuum signal at low RPM's and still allow for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct and above 1500RPM's.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. It is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes.

Graph MAP + Matrix TPS

This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost timing tuning is done on the vacuum timing graph.


Crank Angle Sensor

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Timing Settings >

P3_M2_C Ver 3.5

Crank Angle Sensor

This block is used to guide the ECU to the exact TDC point on all the different type of trigger signals. Then it can synchronize software timing with the actual spark timing.

On gear type trigger wheels the Gear Teeth will indicate to the ECU how many teeth after the slot TDC is situated. The Timing Sensor will do finer adjustments to precisely set the timing in-between the teeth.

For Example if you put the engine of a 60-2 trigger wheel on TDC, you may count the number of teeth from the slot anti clockwise to the pickup sensor plus the one just past the sensor. Then you may adjust the Timing Sensor from 0 to 6 degrees to precisely align the timing light to the tuning software. The example below should work out as Gear teeth 12 Timing Sensor 0 as the last edge of the teeth is in the center of the sensor.

With the engine running match the timing as close as possible by using the Gear teeth setting. Ex. The ECU reads 10° advance, but you see 12° advance on the engine. The Timing sensor °BTDC will now be adjusted to accommodate the difference which is 2. With the Timing sensor adjusted the Timing light and the ECU should now be matched.

Important!
When using an Advance / Retard timing light on a wasted spark system the timing light will double the timing. So if the timing light reads 20° advance, the actual ignition timing is 10° advance. If you are not sure rather put the timing light on zero and use the pulley marks. Remember though we do coil on plug systems they are still fired in wasted spark sequence.

On single event triggers you will find that gear teeth is not adjustable only the degrees between the triggers. On a 4Cyl Nissan for example it may be adjusted to 180 degrees.


Coil Combination

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Timing Settings >

P3_M2_D Ver 3.5

Coil Configuration

This block indicates the type of coil combinations that can be used with this firmware. Some firmware programs will allow the user to select between the different coil combinations on his engine. Note if you have an intermediate or lower hardware class ECU you may only use single coil with distributor. Most coil per cylinder engines is fired in wasted spark configuration and each coil will have its own driver. The Pluto2 and Saturn with internal drivers can fire single coils for 4 Cylinder engines. Mercury2 does not have built in coil drivers so for COP systems the driver output is split to 2 coil drivers. See the wiring diagrams for connections.

The combo files can be loaded into intermediate an advance ECU's. In an intermediate ECU only the single Distributer option will be available. In an advance ECU the tuner my select between single and wasted spark.

Note! On the Rotary programs the tuner may select between coil per cylinder or wasted spark. If the engine has the three coil setup where the leading spark plugs are on a wasted spark coil and the trailing are on coil per cylinder, this value is set on wasted spark, and then connect the two leading coil trigger wires together on the wasted spark coil negative. See the connection diagrams. The charge time for the leadings will combine without overlapping and destroying the coil. Note that on high RPM's the leading spark will become weaker due to less time available to charge the coil. It has to charge twice per revolution.

Dual distributor

Two ignition coil outputs will be activated and phased to run a dual distributor system
Ex. Lexus 1uz-fe, BMW V12

Single distributor

Only one ignition coil output will be activated and phased to run a single distributor

Wasted spark coil pack

Coil outputs equal to half the cylinders will be activated to run a wasted spark ignition coil.
Ex. Opel Corsa C

Wasted spark coil per cylinder

Coil outputs equal to the amount of cylinders will be activated to coil per cylinder. Fired in wasted spark sequence.
Ex. BMW E46 M3

Full Sequencial coil per cylinder

Coil outputs equal to the amount of cylinders will be activated to coil per cylinder. Fired in full sequential mode. Requires a home pulse from a cam signal. This is preferred method for NOZ systems that has fuel in the intake manifold.
Ex. BMW e46 m3

Note that the last COP systems has no performance difference as both types will have a full load on the coil so spark is the same energy.


Coil Driver Selection

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Timing Settings >

P3_M2_E Ver 3.5

Coil Driver Selection

This block select the type of coil driver used by the ECU. If it has internal coil drivers like Pluto2 and Saturn, the installer may choose to select Internal or External drivers. The Mercury2 unit does not have internal drivers so it is set up default to External configuration and this block will be hidden. Note on the wiring of the systems and some may need a Pull-up Resistor with the external selection.

Note that the coils must get their power from the ECU power relay. At startup this relay is kept off till the ECU can read the map to see what type is selected. Having this wrong will destroy the drivers or the coils.

Internal

This is for coils with no electronic drivers. They have a resistance of around 0.8 Ohm and must be protected by the ECU from overcharging. Charging occur between 1 and 5 milliseconds and currents around 6 Amp is normally maximum. These coils normally have two wires and occasionally a screen ground for the iron core or one point of the high voltage side.

External

This is for coils that have built in electronics and requires only a trigger pulse to charge and discharge the coil. In this case there may be a 220 Ohm 10 Watt pull-up resistor required. This is due to the internal driver that can only source a ground signal. The F10 firing modules from Spitronics has these pull-up resistors built in. These coils normally have 3 or more wires. Ground, 12 volt power and trigger pulse. Most of them also has a misfire detection wire for the standard ECU.

It is very important to do this selection before the coils are connected and powered up. This is due to an inverted trigger pulse between the 2 options. If you have it wrong it may destroy the driver and / or ECU. Therefore this block needs to be typed in to change.

Note that this setting may be different if engine maps are loaded into the ECU. The software will prompt you before loading the map. Please read the instruction before selecting Yes or No.


Injector Settings

Help > Galaxy Sotware Ver 3.5 > ECU Settings >

P3_M3_0 Ver 3.5

Injector Settings

See the sub folders for explanations.


Fuel Configuration

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_A Ver 3.5

Fuel Configuration

Start enrichment

This value is set in milliseconds and is added to the calculated fuel once the engine is started and reach 500 RPM. It will then be phased out in a few revolutions. This mixture will help to stable the engine until it runs runs stable.

Maximum fueling

This value is set in milliseconds and is the maximum injector time allowed during running. This value can be calculated and is the time it takes 1 revolution for 2-stroke engines and 2 revolutions for 4-stroke engines. The calculation is for 4 stroke at 7000RPM is seconds=60 * 2 / Max RPM=120/7000 = 0.017 = 17 milliseconds. For a 2 stroke it at 7000RPM is seconds=60 / Max RPM = 60/7000 = 0.085 = 8.5 milliseconds. Now the recommended injector time is 85% of that value which result in 14 and 7 milliseconds respectably. If your duty cycle of the injectors at full load max RPM reaches over 85% you may have to go for larger injectors or increase the fuel pressure to maximum safe pressures. The main aim is to protect against over fueling from all the graphs with accelerator pumps etc.

Start prime pulse

This setting in milliseconds is the initial fuel that will be squirted in the engine to help with starting. It is only injected once the engine starts to crank and not when the ignition is switched on. Half of this value will be squirted as a manual prime function, every time the fuel pedal is pressed more than 20%. This feature is handy on very cold days for starting. If the engine is flooded you may keep the pedal fully pressed to the floor while cranking. This will tell the ECU to cut injectors and only provide spark. Once the engine starts release the pedal and then injection will commence.

Vacuum fuel cut off & RPM fuel cut off

This feature is useful in town and downhill driving and will save fuel. It will let the engine run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip. When the MAP sensor value is below the vacuum setting and the engine RPM is above the RPM setting, the injectors will be cut. There is a dead band feature built into these settings to prevent jerking when cruising close to the parameters. If you feel a jerk when the feature is activated or deactivated, adjust these settings till it change over smoothly. Normally where the change from positive to negative drive is.

Injection teeth

This feature adjusts the start injection degrees. It is only available on gear type triggers as low as 12 teeth per revolution. Normal injection timing starts just after the intake valve closes. The warm valve helps atomizing the fuel and makes the engine use less fuel. Put the engine on the degrees where you want to start injection. Count the number of teeth from the slot or missing teeth in the gear, in an anti-clockwise direction, to the sensor. If the pickup is in the slot imagine the tooth there and count it as well. Even if it is 60. The firmware will move injection in the slot to the closest teeth as this is not as critical as spark timing. You may during tuning change this value to see if you get better atomization and performance increase.

TPS Gain

This setting will adjust the rate at which the TPS sensor will move the MAP bar to the right of the graph during Graph Map + TPS calculation mode. This will simulate a MAP signal and the gain adjustment will produce the right amount of fuel during pull-off. See tuning further in the manual.


Accelerator Pump

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_B Ver 3.5

Accelerator Pump

Accelerator pump selection

The accelerator pump setting is used to richen the fuel mixture when accelerating to avoid flat spots or bog. Here you can select not to use it, use either the TPS or MAP or both signals. Below is the selections to setup each pump for TPS and MAP.

Enrichment %

This is the amount of fuel that will be added momentarily when the accelerator pump is activated. This value is divided by the number of strokes and each stroke the value is reduced by the division value. It will start with 10 and reduce to zero so that fuel is gradually reduced. This value is also compensated with the water temperature graph value. In Expert mode this value will be blanked out and the graph value for that temperature interval will be used.

Sensitivity

The activation sensitivity can be adjusted from 1 to 10. The lower the value, the more sensitive the accelerator pump will be. If the accelerator pump is set too sensitive it will activate randomly and cause the vehicle to over fuel. Rather keep the activation sensitivity as high as possible to avoid this from happening. For the TPS signal this value can be lower as it is more stable than MAP value and it reacts faster.

Max RPM

This is the maximum RPM that the pump settings will be active. At high RPM you do not need an accelerator pump. A standard is 1500 to 3000 RPM for TPS and 1500 to 2200 RPM for MAP. If a value was initiated before this limit was reached it will finish the decay cycle.

Strokes

This is the number of engine firing strokes that the fuel must be applied and decayed over the amount of cycles. If it is a 4 cylinder engine, a value 0f 8 will inject 4 full revolutions of fuel. There are two firing strokes per revolution. If it was a 6 cylinder engine, a value 0f 12 will inject 4 full revolutions of fuel. Always tune for the lowest value to eliminate flat spots. If a value of example 10 is selected it means that the enrichment amount will be decayed by a tenth every cycle till the tenth stroke.


Injection Type

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_C Ver 3.5

Injection Type

This setting will allow different methods of fuel injection. The firmware in the ECU will blank out the methods that is not adjustable.

Batch Injection

This method pulse all the injectors for all the cylinders at the same time. It is not good practice as the cylinders does not get the fuel under the same conditions or injection angle and is poor on power and economy. Spitronics programs does not use the feature unless for specific tasks.

Split Batch Injection

This method will pulse two sets of injectors 180° apart from each other. It is used where the trigger has even pulses and no cam signal is present. It is used on the standard systems where budget is of importance. For a 4 cylinder the injectors is paired so that each cylinder gets fuel under the same condition or injection angle.

Split Sequential Injection

This method will pulse two injectors per driver together for the two cylinders that move at the same crank degrees. It will follow the sequence of the firing order. There may be 2 to 6 drivers in the sequence. The injector will pulse once per RPM and the injection time on the software will be divided in two. With other words for each RPM only half the calculated fuel is injected. This method does not require a home pulse and is the popular choice. There is very little difference in power and economy to a full sequential system.

Full Sequential Injection

This method will pulse one injector per driver in the same sequence as the firing order. The injector will pulse once every two RPM's and it will inject all the fuel in one squirt. Here a cam pulse or home signal is required to sink the injectors with a certain stroke one the engine. If there is no home pulse it will still do full sequential injection stroke phasing may vary from start to start. Note that an engine is normally started in split sequential mode and then go over to full sequential after 500 rpm is reached. This helps for faster starting. This feature is mostly for Mercury2 which has enough drivers for engines up to 8 cylinder. Here specific firmware needs to be developed for each engine due to the cam signals type and position.


Throttle Selection

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_D Ver 3.5

Throttle Selection

This setting is developed to use a MAP signal on multiple throttle body engines. The problem with them is there is no intake plenum where the vacuum could be measured. The vacuum signal only makes a spike when the valve opens. This spike is also there only once in 2 RPM's. This makes it important to read the signal on crank degrees when the vacuum signal is present.

Single

Most engines have one throttle and an intake plenum where this method is used. The map signal is read 2 or 3 times per revolution. It makes for a fast vacuum signal response. The map teeth can still be adjusted here as there are a little bit of pulsating in the intake plenum.

Multiple

To use this method a crank gear of min 12 teeth is required and the MAP sensor is only connected to cylinder 1 or the cylinder that shares the crank degrees on movement. With other words are on TDC with cylinder one. This feature the MAP sensor is read once per two RPM's when there is vacuum on multiple throttles. This makes for a slow response that may cause flat spots during blip. This however can be cured with the accelerator settings. One requirement is that the throttle are properly balanced as only ones vacuum is measured. The map teeth setting here is very important. When the engine idles it is adjusted to read the best vacuum. The more teeth on the crank gear the finer adjustment could be made to find the sweet spot.


Fuel Calculation

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_E Ver 3.5

Fuel Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual.

Graph MAP

This is for standard engines with a good vacuum signal and allow for easy tuning in the street.

Graph MAP+TPS

This is for standard engines with a poor vacuum signal at low RPM's and still allow for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct above 1500RPM's.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. Note that is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes.

Graph MAP + Matrix TPS

This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note that is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost fuel tuning is done on the vacuum timing graph.


Injector Trim

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Injector Settings >

P3_M3_F Ver 3.5

Injector Trim

This block will allow the tuner to trim each injector individually for the ultimate performance. This is done by individual Lambda or EGT sensor on the exhaust runner to measure air fuel ratios. It is only certain Mercury2 firmware that has this feature.

Trim Count

This is the number of drivers selected by the tuner. The Mercury2 has 8 injector drivers and can work full sequential for 8 cylinders. At can also run duel injectors full sequential for 4 cylinder engines. A setting of zero will disable this feature.

These tuning blocks allow the tuner to adjust the register from 90.0 to 110.0 % for each cylinder. Adjustments can be made in 0.5 % resolutions.

This block is to clear all the registers to 100.0 % to start with. First the engine is tunes as good as possible then minor changes is done here.


TPS

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_0 Ver 3.5

Sensor Settings

See the sub folders for explanations.


Active Sensors

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings >

P3_M4_A Ver 3.5

Active Sensors

This block let the tuner select the different sensors that he requires for his application. Not all the sensors are used but each one has different features that makes the engine perform at its best. If a sensor is not used, leave the block unchecked. This will free up valuable processor time. Also make sure the wiring to that sensor is properly isolated as there is power on the leads that could short circuit and damage the ECU as a result. Some of the sensors cannot be altered or will be forced on by the firmware.

Calibration
 Some of the inputs can be calibrated by clicking on the calibrate button. This allows for a wider range of sensor to be used and calibrated in the software.

See the sub folders for explanations.


MAP

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A2 Ver 3.5

MAP Sensor

This sensor measures the MAP (Mean Absolute Pressure) in the intake plenum. This is the main sensor for the ECU to calculate the fuel amount which is injected into the engine at different conditions and load requirements. This sensor does have its shortcomings when it comes to engines with overlap cams where the intake vacuum falls away at low RPM's. Then the ECU need to rely on other type sensors like TPS or Mass volume in conjunction to air temperature, altitude and RPM's. For multiple throttles this sensor also is in adequate but there is a feature that the ECU can use to remedy this. See multiple throttle bodies.

This calibrate button will only appear when the custom sensor is selected.

If you click calibration this block will appear. The offset value will change the MAP reading. Adjust it the same as the barometric pressure of your altitude above sea level. Remember to take temperature into account.

`

The Filtered checkbox can be used to smooth an erratic map sensor signal. It will average the current sample with the last sample. The down fall is that it may create a minor flat spot under blip conditions. This need to be corrected with the accelerator pump feature.

The sensor must to be set up correctly by selecting the Type and range under Engine Configurations.

If the sensor is not used uncheck it to free up valuable processor time.


Aspiration

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings >

P3_M4_A3 Ver 3.5

Altitude Compensation

The ECU can compensate for altitude differences in pressure. It will adjust the fuel mixture and the timing in relation to altitude. Pluto2 and Saturn has an optional on-board map sensor which can be used for altitude. This is optional and has to be ordered separately. Note that with Ver 3.5 the altitude sensor must be the 1.1 Bar type and not the 3 Bar. So make sure of your application before ordering. The Mercury2 can do Altitude compensation by wiring an external 1.1 Bar Map sensor onto it.

The Aspiration function is reserved for future use and is locked in Normally aspirated at this satge.

Select Altitude and click on Compensate. The Altitude sensor is pre calibrated. You do however need a 1.1 Bar MAP sensor. The real time bar below will indicate the actual altitude pressure of your surroundings.

Fuel Compensation

This is important because the normal MAP sensor will not reach the maximum scale on the tuning graph at high altitude. In a typical fuel graph for vacuum in the example below, an engine was tuned at sea level where the MAP sensor reached 1 Bar. Now at around 2000 meter above sea level the graph will only reach 0.83 Bar which means it will not reach the hump in the graph where extra fuel is added for full throttle. It also did not cross the red tuning bar so it means the high RPM Fuel will also not be used to enrich the total RPM range at full throttle.

The ECU will use the Altitude sensor to measure how much air pressure is available and then scale MAP sensor to reach the tuning max at 1 BAR. In the example below is the same engine at 2000m but with altitude compensation activated.

As you can see the blue bar is the altitude sensor, and it now indicates 0.83 Bar where the MAP sensor used to be, but the MAP sensor now stands on 1 Bar at full throttle. And this is at high altitude. Now the ECU will use the altitude sensor to calculate the fuel adjustment. In this example at sea level without altitude sensor and at 1 Bar the ECU calculated [image] . At 2000 meter it calculated [image] without altitude sensor. With Altitude sensor activated, it then calculated [image] . As you can see the difference is due to the MAP bar not reaching the hump at the right hand of the graph. The difference in pressure is around 16% which calculates to 14.3 milliseconds. Notice first and last calculation was both at 1 Bar on the graph but the fuel is reduced at altitude.

The same system applies for the Matrix tuning. For racing applications where TPS versus RPM fueling is used, the altitude sensor becomes even more important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel with pressure difference to ensure a more accurate fuel mixture. The TPS versus RPM tuning is normally for engines with throttles or poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you decent to sea level the fuel will be added.

Timing Compensation

Under Timing Settings set the Altitude Comp to 3 degrees per 1000 meter.

With timing compensation the ECU will gradually add timing with increase of altitude. The tuner can select the number of degrees advance per 1000 meter increase in altitude. In this example we used 3 degrees which result in 1 degree for every 333 meters. Note that this will advance the calculated timing in total. There is no extra graphs to tune.

You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the added degrees so that when you decent to sea level the timing will be retarded.


MAP/Alt Swop

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A4 Ver 3.5

MAP/Alt Swop

This feature is for Pluto2 and Saturn which has an optional onboard MAP sensor. If this block is unchecked the external MAP sensor is used and an optional 1.1Bar internal altitude sensor may be used. When the block is checked then the internal optional sensor becomes the map sensor. It may be 1.1 bar 3Bar or 4Bar. Then the external sensor becomes the altitude sensor, it must be a 1.1Bar sensor.


Water Temperature

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A5 Ver 3.5

Water Temperature

The water temperature sensor is used mainly for cold start compensation with fuel and spark timing. There is however a couple of functions that do compensate with this signal like idle control, accelerator pump, prime pulse etc. Neglecting to wire it in may result in the engine not being drivable when it is cold. It uses a 2K NTC (Negative Temperature Co efficient) resistor. It is the popular sensor under most engine manufacturers. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Water sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the fan must come on or off. If the error is large you may need to replace it or get the correct sensor.

These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 2K sensor. Save to ECU [image] button will make the changes permanent.


Air Temperature

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A6 Ver 3.5

Air Temperature

The Air temperature sensor is used to compensate with fuel and spark timing for density changes in warm or cold air. Neglecting to wire it in may result in the engine detonating when it is Hot. It is a 10K NTC (Negative Temperature Co efficient) resistor. This sensor deviates plenty between manufacturers so it is difficult to cater for all types. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Air sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the engine is at running temperature. If the error is large you may need to replace it or get the correct sensor.

These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 10K sensor. Save to ECU [image] button will make the changes permanent.


Fuel Sensor

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings >

P3_M4_A7 Ver 3.5

Fuel Pressure

The Mercury2 ECU has the ability to control fuel pressure by speed controlling the fuel pump with Pulse Width Modulation. This is achieved by pulsing the driver at 300 Hz, with a required duty cycle and then measuring the actual fuel pressure with an electronic pressure sensor. The duty cycle is then adjusted to reach the required fuel pressure in loop control. At startup for the first time disconnect the P2 and P3 connecters till you have set the control up properly. Reason is that the ECU may start the pump at full pressure and damage the lines.

This advantage of this feature is that the ECU can compensate for pressure fluctuations as this will vary the fuel amount going through the injector. It also eliminates the need for a fuel pressure regulator and return line to the tank. It can also compensate for turbo engines to increase fuel pressure above manifold pressures.

There are a few requirements to ensure stability of the fuel pressure. The fuel pressure sensor must be mounted higher than the fuel line where it is connected. The pipe must go downwards from the sensor to the fuel line. This will ensure a pocket of air between the sensor and fuel which will suit as a damping effect and isolate the sensor from the fuel to enhance reliability. Use high quality fuel hoses and clamp them properly to the sensor and fuel line. The ECU does have shutdown protection should the pipe come off and pressure signal falls below a certain level. There will however spill petrol as the pump has momentum and the one way valve will prevent the fuel in the rail to return to the tank. This fuel is under pressure so it will spill at the severed line. Do not mount the fuel pump close to the exhaust as it will heat up and the fuel will percolate. The air pockets will cause the cavitation in the pump resulting in erratic pressure. This air bubbles can only be perched through the injectors which also result in incorrect mixtures.

To use this feature proceed with the following steps. Start by switching the sensor on. Click on show graph.

Click the calibrate [image] button and type in 100. Click OK. If you have an accurate fuel pressure gauge or a different fuel pressure sensor you may calibrate it with this value. It is a percentage correction which allow only for range calibration. That means calibrate is accurate at the working pressure. The sensors supplied are calibrated according to the manufacturer signal specs.

Now set up the following parameters.

Fuel sensor value

Type in the Fuel sensor value that you are using. They come in 4 Bar Map, 5.5 Bar Differential pressure, and 7 Bar Map. The most popular sensor is the 5.5Bar. Note that the low pressure side of the sensor must be tied to the intake manifold pressure just as a normal fuel pressure regulator. This sensor will automatically compensate for the intake manifold pressure.

The fuel pressure real-time bar will also be scaled to this maximum.

Fuel Control sensitivity

This setting will adjust the how the ECU will react to pressure changes. Fast or slow reaction will control the pressure range. 1 is for the fastest reaction. If it is set on too fast the fuel pressure will become erratic. Select the fastest value at which the pressure will not hunt.

Fuel Safety Pressure

This setting is the protection feature that will cut the fuel pump in case of fuel line breakage. Especially to the sensor as this is a thin line. Use a 1 Bar setting.

Fuel Pump Low

This setting is to control the minimum duty cycle of the pump. If it is too low the pump will stop start and make the fuel erratic. Some fuel pumps need to do a minimum RPM or their veins will not deploy to pump fuel. If this is the case the pump will start to make funny noises and the fuel pressure becomes erratic. Sometimes it helps to turn the pump position so that the veins protrude downwards. Set the minimum duty cycle so that the pump run smooth at lowest pressure. If it is too high the pump will not be able to control at the lowest pressure. A value out of 254 will make up the duty cycle, it means that 127 will be 50% duty cycle.

Fuel Pump High

This setting is to control the maximum duty cycle of the pump. The high setting will limit the pump at a certain pressure. This is handy to prevent the pump from over pressure on the thinner fuel lines to the sensor. Do make sure that the pump can supply the right pressure at full load high RPM. Always go for the lowest setting and keep a note on the fuel pressure at high load.

Now you need to set the graphs correctly. Click the page button

There are different ways to set this control system up. With the 4 & 7 Bar MAP, (Mean Absolute Pressure) sensors, you need to compensate on the graph for manifold pressure fluctuations. The reason is that the Map sensor do not compensate for manifold pressure like a fuel pressure regulator. The fuel pressure need to be adjusted with manifold pressure to keep a constant over the injector. This settings in the graph below will keep a constant pressure of 2 Bar over the injector through the manifold pressure range.

For the 5.5 Differential pressure sensor the compensation is automatic as the open line is connected to the intake manifold. This settings in the graph below will keep a constant pressure of 2 Bar over the injector through the manifold pressure range. If you leave the line open to atmospheric pressure it will result in fuel pressure variations with altitude and will influence tuning of the engine.

For Turbo engines with the Map sensor the graph below will keep a constant pressure of 2 Bar over the injector through the manifold pressure range. Note on the graph below how the pressure increases to 5 Bar at 2 Bar boost pressure. For the 5.5 Differential pressure sensor the compensation the graph will be flat as the graph above.

The fuel pressure compensation graph will allow the ECU to compensate for fuel pressure variations during blip conditions where the injectors suddenly draw more fuel. The fuel pressure signal will react faster than the pump can be speed up or slow down due to mechanical delays. Here the injector opening times will be manipulated in order to add or reduce fuel for pressure variation. To set this graph, start with a flat line. Load the engine at light cruise settings like 2000 RPM and say 20% throttle. This may be varied as the type of engine may be happy at different RPM's. Now adjust the fuel mix to be in stoich area. Now increase the fuel pressure by half a bar increments. Do not go too high as the fuel lines may burst. Every time adjust the graph lower to maintain the same fuel mixtures. Now reduce the pressure and increase the graph again to stay in the right mixtures. Put the pressure settings back to normal.

Now as fuel pressures vary to control variations the injector times will be compensated for and the A/F Ratio will remain constant. These graphs are interpolated.


Battery

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A8 Ver 3.5

Battery Voltage

The ECU can compensate for battery voltage variation. The reason is that voltage will influence the charge time of the coils and the speed at which the injectors open. This means that when voltage drop to certain levels the spark will become weaker and the fuel mixture leaner. To compensate for this there is a graph where the coil charge time and the injector time could be compensated according to voltage drop.

Click on the page [image] button. Now you can set the graph according to the sample.

The blue graph adds a certain percentage to the injector time and the red one add a certain percentage to the charge time. This is not an easy one to tune but it is recommended to lower the values and see if the result is better or does not make a difference in starting. Always go for the lowest values. You may also decrease the values with higher battery charge. This may help protecting the coil drivers. These graphs are interpolated.


Lambda Control

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings >

P3_M4_A9 Ver 3.5

Lambda

This ECU has the ability to do loop control with the lambda sensor and the injector time. The tuner may set up parameters for lambda control and then the ECU will compensate air fuel ratio according to the lambda sensor in real time. This will result in the optimum mixture even if all the maps is not setup accurately, or due to variations in environment which is difficult to tune such as moisture, air density etc. You need to tune the engine properly first and then activate this control afterwards.

To setup this feature click on lambda and then show graph.

Target volts

This is the desired Stoich area where the sensor determine the best mixture of 14.7 air to fuel ratio. These narrow band lambda sensors have a voltage output of 0.1 to 0.9 volt. A voltage of 0.45 volt = 14.7 A/F ratio = 45%. We work in % as this is easier to simplify between the 1 volt and 5 volt signal. This unit can receive a wide band signal of 0 to 5 volts but the electronics for driving the sensor is not in the ECU. It will require a separate electronic board. The ECU does not convert this volt signal in A/F ratio or lambda values as it is not required for control. There is a difference in volts for different type wide band sensors. The tuner use an accurate test instrument to tune the engine and set his A/F Ratios correctly in real time.

Startup delay

This will give the sensor's element time to heat up so that it can measure accurately. A normal setting here is 30 to 45 seconds. If the temperature of the engine is below 30°C then lambda control will be disabled. When you start the engine time the sensor with a stopwatch till you can see that it measures corectly.

Control %

This is the value of injector compensation. It can be adjusted from 0 to 20%. This means that if on 10%, the ECU will lengthen or shorten the injector signal by 10% to achieve stoich. Always try and tune the engine accurately on open loop and give the lambda just a little control to smooth it out. If you give it a large % and the sensor fail your engine may be out of A/F ratio tuning.

No. Samples

This number is the number of samples that is used as an average to prevent the control from becoming erratic. Because the sensor has a 0.6 seconds reaction time the ECU tends to over react. Increasing the number of samples for more stability to the control program.

The 3 limits

This will set the control range where the narrowband sensor is accurate. A narrow band sensor cannot always control where a slightly richer or leaner mixture is required. The control will be active between the RPM limits and below the vacuum limit. Do not use this control at high RPM and high boost. It may be too slow to react when a mixture are lean.

Sensor input

This input is used to select between a narrow band 1 volt signal and a wideband 5 volt signal. A wideband signal is linear and can cover a wider range of A/F measurements. It can be used for idling and high load readings.

Now click on the Lambda page [image] button.

On these two graphs you can manipulate the target voltage of the sensor for control by the ECU. This means if you have a 10% increase on the graph and the target volts is on 45%, then the ECU will use 49.5% as the new target volts. Now remember on a narrow band sensor this makes a larger difference in fuel as on a wide band sensor. Normally a car idling or under load requires a richer mixture. The top graph compensate according to load and the bottom graph according to RPM. These graphs are interpolated.

The dark green bar is the Real Time Map value and the light green bar is your cursor position for adjustment. The red bar is the lambda vacuum limit.

The Brown bar is the Real Time RPM value and the light green bar is your cursor position for adjustment. The dark green bar is the minimum lambda RPM and the Red bar is the maximum lambda RPM. So the lambda sensor will only be active between the minimum and maximum range.

The real time lambda display is shown on the right hand status bar. It will show a small graph to ease with tuning. If you double click on it a normal bar is displayed.


Launch Control

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M4_A10 Ver 3.5

Tuning POT

This potentiometer or variable resistor is a handy tool that let the tuner or driver change settings in real time while the ECU is operating. It is a device that connects to the communication port plug for Pluto2 or Saturn or can be wired in permanently on Mercury2. The following functions can be activated for it.

See the sub folders for explanations.


Injector

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > POT Input >

P3_M4_A10a Ver 3.5

Tuning POT Injector

Injector will change the injector time with 10% in the example richer or leaner. The POT needs to be in the middle to have no effect on current fueling. This is handy in a race car if the driver has an A/F Ratio gauge installed. Then he can manipulate fueling and remember under which conditions he has to lean or richen the mix. Then he can make adjustments on the graph at a later stage.

Example; When a Pot register of 10 has been selected the Pot will give a total of 10% increase and 10% decrease in injector time from the center position.


Timing

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > POT Input >

P3_M4_A10b Ver 3.5

Tuning POT Timing

Timing will advance or retard by 5 degrees in this example. The POT needs to be in the middle to have no effect on current timing. Again useful as racing tuning provided the driver has a knock sensor and light fitted to the engine.


Launch

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings > Launch Control >

P3_M5_A10c Ver 3.5

Launch Control

The Launch control feature can be used for Launch control, Anti-lag, or transmission shift retard. The driver will have to set it up for one of them. These features came later than the hardware so plans were made to accommodate them in this hardware. It is also mainly Mercury2 features.

Launch Control

This feature will adjust the RPM limiter, enrich the fuel mixture and retard the ignition timing. These parameters are implemented in different ways to suit the driver. Launch control will spin the turbo to higher RPM's while the vehicle is stationary. This will create boost pressure so that when the driver launch, there will be no turbo lag. These Launch settings will only be implemented the moment engine revs reaches Launch revs minus 500RPM. Example if the limiter is set as 5500RPM then the timing and fuel compensation will only start above 5000RPM. This will help the engine to rev up to launch effortlessly. Should the engine revs go above 5500RPM the fuel will be cut to limit the engine from over revving. Spark will continue to ignite unburnt fuel. See the Product Hardware description for different wiring options.

There are basically 2 methods to implement this feature. One is with a switch and one is semi-automatic. For both methods set the Tuning POT selection on Launch.

Method 1 (Switch or Clutch and switch)

Select Clutch under Launch Deactivation. Set the desired RPM limit normally lower than engine limit. 4500 to 5500 is mostly preferable depending on the grip at racing track. Timing is set from 1 to 10 depending of the engine characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which is the power to spin the turbo. Now to activate this feature.

If you have only wired the Dashboard switch you only need to press the switch and press the accelerator pedal. The moment you need to launch just release the switch with the clutch.

If you have the switch and the clutch pedal switch and resistor, you press the clutch in to make the Clutch Pedal switch, press the Dash Board switch once and launch is activated. No need to keep the Dash Board switch pressed. Press the accelerator. The moment the clutch is released the launch switch will break and launch is deactivated. To activate this feature again you need to repeat the procedure. This feature let the driver concentrate on his pull-off and not switch and clutch timing.

Method 2 (TPS 90% - Semi-Automatic)

With this method you do not need to wire the Clutch button in. You do however need the Dash Board on/off switch or the Tuning POT installed. This method requires the driver not to press the pedal over 90% during launch activation. Pressing it deeper will deactivate launch to normal settings. The driver may need to practice this. He may also use a GP output to switch a light on at 80% TPS to ensure that he do not press it too deep. Both methods require the engine to rev lower than 3000RPM before activating the launch feature. This will prevent the feature from activating during gear shift.

With the Dash Board switch do the following settings:

Select TPS 90% under Launch Deactivation. Set the desired RPM limit normally lower than engine limit. 4500 to 5500 is mostly preferable depending on the racing track grip. Timing is set from 1 to 10 depending of the engine characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which is the power to spin the turbo. Now to activate this feature.

Switch to on position. Now press the accelerator no more than 90%. The launch parameters will spin the turbo. When the driver release the clutch he also press the accelerator 100%. This will deactivate the launch feature. To activate this feature again you need to repeat the procedure except the switch that is already on position. Note that the rev must be lower than 3000RPM. To deactivate put the switch off

With the tuning POT do the following settings:

Set the desired RPM limit to 0. This will indicate to the ECU that it must use the POT value to calculate a limit value. Now set the POT register to the maximum allowable launch RPM. Example 55 means 5500RPM. This will mean that when the POT is turned fully clockwise it will be 5500RPM.

This feature is useful as different tracks give better traction and allows for higher launch PRM's. To activate this feature the driver simply press the clutch and press the accelerator till just below 90%. Now he adjust the tuning POT till he sees the desired RPM on his rev-counter. When he release the clutch he press the accelerator 100%. Launch will then deactivate. This feature will activate automatically once the revs falls below 3000RPM because it does not have the Dash Board switch. If you want to cancel this feature set the launch revs 500RPM above the normal engine limiter. Then turn the POT fully clockwise. He may need to increase the pot register to 500 above maximum engine revs. He can also make increments on his tuning POT to calibrate it to his engine revs.


Anti-Lag

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings > Launch Control >

P3_M5_A10d Ver 3.5

Anti Lag

The Anti-lag function will help to keep the boost pressure up wen decelerating in corners on the race track. This function will use the launch control settings which will add fuel and retard the timing. The correct installation requires a valve to bypass boost air from the turbo before the throttle body, into the exhaust between the engine and turbo. The extra fuel with this air will ignite and the pressure will cause the turbo to spin creating boost. If the valve is not installed then the min throttle setting must be opened slightly as to let air pass through the engine to burn the excess fuel. This may cause the engine brake to be eliminated and the driver will need to rely more on his pedal brakes.

Settings

Enable the feature and set the minimum RPM setting. This RPM setting is the limit which will disable the function. If the engine revs fall below this value normal fuel economy cut will presume. During racing the driver will gear down keeping the engine revs high.

These two setting will activate the Anti-lag. When the boost pressure fall below the Vacuum fuel cut off value and the throttle position is below the TPS idle cut off value. When the boost pressure goes above the Vacuum fuel cutoff the feature will be deactivated and normal functions will presume.

To disable the normal Econo Fuel Cutoff function make this value high.

The launch settings used for the Anti-lag feature. If it is activated the timing will be retarded to the launch timing and the fuel will be enriched to improve burn pressure in the exhaust to spin the turbo.

For valve wiring and output connection on the ECU consult the specific firmware instructions and drawings.


Trans Retard

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings > Launch Control >

P3_M5_A10e Ver 3.5

Transmission retard

This feature is for automatic transmissions to retard the engine timing during gear shift. This will make the shift smoother and protect the transmission. The launch control circuit will be used.

Set the tuning POT on.

Put the POT on launch and make the launch register zero.

Put the RPM limit on zero. Put the launch control timing on 5 to 15 degrees depending on the feel of the shift in the transmission. Launch deactivation must be on Clutch. Fuel enrichment is not used here.

Now connect the relevant wires from the TCU to the ECU. When the TCU makes a shift it will put a negative driver on. It will go to the POT input of the ECU. The POT real-time bar will be high and the moment of shift it will go low activating the retard feature.


Trigger Signals

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings > Active Sensors >

P3_M4_A11 Ver 3.5

Angle Sensors

These inputs are required by the ECU to determine exact crank and the cams angles so that spark and injection timing can be calculated. VVTI cams can be positioned by the ECU. Their cam signals will be compared to the crank signal to determine the right position for loop control. (Still under development)

The firmware may blank out or force the signals in a state depending on the specific engine. On the crank trigger is a test function. This will activate a test of the crank sensor pattern to ensure that it is read correctly. If it is incorrect or the wrong firmware, the software will show errors and not start the engine. The errors have numbers indicating a fault code and description.

Trigger signals also have a rising or falling edge selection. This will indicate to the ECU on which edge of the pulse to start calculations. On magnetic type sensors there is a positive and a negative wire. If it is wired incorrectly the tuner may select the rising or falling edge in software without the need to change the wires around.

On a Hall sensor it must be wired correctly. But certain encoders my use the rising or falling edge of the signal. The reason is that the signal varies in length but a certain edge is used which is equally divided into crank angle degrees. Note however that the Hall sensors do require a pull-up resistor to work correctly. This is selected by jumpers.

The Mercury2 ECU trigger signals goes through isolating capacitors giving it the ability to tap into existing magnetic trigger signals. Note the wiring diagrams and make sure you use the correct wire. The reason is there is always a reference wire that is ground from the Mercury and also a 12V signal that are required for the Hall or optic type sensors. When tapping into a sensor do not connect the Mercury2 reference wire to the existing sensor only the signal wire. Connecting two reference wires together which are at different voltage levels will damage one of the ECU's.


Idle Control

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Sensor Settings >

P3_M4_B Ver 3.5

Idle Control

The ECU has the feature to control different types of idle motors found on an engine.

Before adjusting the idle control settings you need to select which type of valve or stepper is on the engine. Note that the stepper type idle motor (4 to 6 wire), require the external electronic driver. Also note that the electronic unit differs between the 4 Wire bipolar type motor and the 6 Wire common supply type motor.

Type Selection

The Type Selection can select between the two-wire spring-loaded Idle Valve, the three-wire spring or non-spring loaded Dual idle valve, the Bipolar Stepper motor or common supply Stepper motor. Stepper motors do not use the Low Limit and High Limit settings as they keep their position when there is no signal present. If there is no idle control select Not used to free up valuable processor time.

Idle Valve
Two wire spring loaded idle valve

Dual Idle Valve
Three spring or non-spring loaded idle valve. Picture below is a non-spring loaded idle valve

Stepper Motor
Four or Six wire idle valves operate with a Spitronics Type 1 or Type 2 stepper motor controller. Picture below is a 4 wire bipolar stepper motor

Settings

Drivers

This indication will show the installer which wires to use for which type. Driver 2 is only used for the dual valve to close. Note that positive and negative drivers may be used for idle control. If a valve is used then make sure the Diode is wired correctly. If it is a stepper control module then there is a pull-up wire that may go to positive or earth.

RPM

This setting is the preferred target RPM's when the engine is on running temperature. When it is cold the ECU will automatically increase engine RPM's with up to 300 RPM's. This is calculated according to fuel enrichment on the water compensation map. Every 15% will increase 100 RPM on the Idle control.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve with this %.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the aircon on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster the response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the solenoid against the spring in the idle valve so that the valve starts to open immediately when the ECU starts increasing the value. It can also be used to set minimum idling RPM for throttle valves that closes completely. To set the value start with a larger % and decrease until the desired idling RPM is reached.

High Limit duty cycle

This setting is used to limit the maximum idle RPM's. No need to open the valve more than necessary. It also allow for the use of large valves in smaller engines. Make sure that when the engine is cold, it can still lift the RPM up to approx. 1500 RPM. This can be tested by entering a large Idle RPM value and see to where the ECU can increase the RPM to.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a little bit of revs with slight throttle.


Turbo Settings

Help > Galaxy Sotware Ver 3.5 > ECU Settings >

P3_M5_0 Ver 3.5

Turbo Settings

See the sub folders for explanations.


Engine Limiter

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M5_B Ver 3.5

Engine Limiter

This block has a few protection features. Setting them may prevent the driver from damaging the engine in normal and racing conditions.

Boost limiter

This feature will cut the injectors clean if the MAP sensor detects a manifold pressure that is higher than the set value. It is not a boost controller but it is to protect against boost controller or waste-gate failure. It can be adjusted in tenths of a bar resolution. The spark will not be cut.

Over temperature limit

This feature and the next one will protect the engine against over temperature. The injectors will be cut until the revs fall below the next setting.

Temperature RPM limit

This is the maximum limp mode RPM's when the engine is over temperature. If it is due to a burst hose it is better to switch off before the engine is damaged. If it is due to low water the lower revs will help to cool it down instead of disabling the engine.

RPM limit (>=60°)

This feature will prevent the engine from over-revving under normal temperature conditions. It can be adjusted in 100 RPM intervals. RPM limit can be achieved by three methods.

Soft

This mode will retard the timing in three stages and then cut the fuel completely. The result will be a smooth soft loss of power. Each 100 RPM over the limit the timing will be retarded further. First retard is 15 °BTDC, then 10 and then 5 °BTDC. Then during the third stage, fuel will be cut but not the spark. This will prevent fuel from entering the exhaust and backfire there. This is the preferred method for engine over rev limiting. Note that the engine may reach 300RPM above the set value.

Hard

This mode will cut the fuel and spark completely. It has a jerk feel and may result in small detonations in the exhaust.

Spark Only

This mode will cut only the spark. This will give the backfire sensation when unburned fuel is ignited in the exhaust. Note that damage to the exhaust system might occur in this method.

RPM limit (>=60°)

This feature will prevent the engine from over-revving under cold temperature conditions. It can be adjusted in 100 RPM intervals. RPM limit can be achieved by three methods. This method will only cut the fuel and is just a protection.


Micro Fueling

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M5_C Ver 3.5

Micro Fueling

The Mercury2 ECU has a few features where it can use 2 injectors per cylinder. The way these injectors are implemented vary for different applications. If you use one fuel and the primary and secondary injectors does not differ too much in size, then the Ratio method is preferred. If you want to use different fuels together and the secondary injectors is a lot bigger than the primary injector then the Graph method is preferred. On the hardware side, there is also different wiring configurations for different firmware. If there is enough drivers for all the injectors then they can be used. If there is not enough drivers then an extra electronic relay is used to power the secondary injector's separately. So please note on the wiring diagram. The hardware connections does not affect the software settings.

If you are not using micro fueling set it on OFF to free up some microprocessor time.

Ratio Micro Fuelling

This feature use only the primary injector at low manifold vacuum and when the manifold pressure goes high, it will add a secondary injector to increase the fuel amount to the engine. This will allow the engine to be tuned more optimized on low and high loads. This is necessary for high boost applications where the range of the injector's usage become limited. There are 2 limit values and the ratio value. If any of the two limits are reached the micro fueling will be activated.

The ECU will calculate the difference in injector time between one and both injectors, so that the same amount of fuel enters the engine under the same conditions. This method should make the transition as smooth as possible. This is done by decreasing the total injector time by a fixed % which is calculated in the explanation below.

The Injector ratio adjust % field is calculated by the primary injector cc divided by the total injector cc multiply by 100.

Example: Primary = 100cc, Secondary = 200cc.

Compensation = Primary Injector x 100 = 100cc x 100 = 33%

Primary + Secondary Injectors 100cc + 200cc

If you are not sure on the injector sizes set the 2 limit values high so that the secondary injectors stay off. Tune the engine at 3000RPM's with the primary injectors up to a load where the injector duty % is around 70% [image] . Set the A/F Ratio with the Fuel Ratio setting [image] to be at stoich. Now start with 50% Injector ratio adjust value. Decrease the 2 limit values so that the secondary injectors start to operate. Reduce or increase the Injector ratio adjust % so that the same air fuel ratio at the same load is reached. You may need to reduce the vacuum with the throttle to stop the injectors, while changing the Injector ratio adjust %. Now reset the Fuel Ratio setting [image] to 100%.

The Injection duty limit is the one value where the secondary injectors will be implemented. If you set it at 70% then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector duty cycle.

The Injection duty time is the second value where the secondary injectors will be implemented. If you set it at 12 milliseconds then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector time.

Note that there is a dead band implemented on both limits so that the injectors does not become erratic at the changeover load.

Graph micro fueling

This feature is ideal for Methanol Injectors. It will not influence the primary injector time like the ratio method. It will just bring a secondary set of injectors in at a certain boost pressure and progressively adjust the injector time for the secondary injectors on a graph in milliseconds. If you select Graph a second graph on the Fuel graph will become visible. Click on the fuel graph menu [image] button and set the graph as follows.

The brown graph will be for the primary injectors and the blue graph for the secondary injectors. There is no real time display for this value but the milliseconds is exactly as on the graph where the orange boost bar cross. Note that when these injectors do come in working zone, you need to keep the primaries constant or reduce them under the same pressure. The reason is that they may be close to the maximum duty cycle of 100%. This graph is interpolated.

Check the relevant drawings of which drivers will be used for this micro fueling.


Cam Selection

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M5_D Ver 3.5

Cam selection

This block if for future use and not yet implemented.


VVTI

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M5_D Ver 3.5

VVTI

This block is used to set up open loop cam control with TPS limits. It is also used to open variable intake runners found on some engines like the Lexus 1UZ VVTI. In some cases part of this block may be hidden or disabled like in the example.

Cam1

In this block the output will be on between 1900 and 4200 RPM if the TPS value is above 20% this is how most V-Tec cams are applied. The driver output will indicate where the solenoid must be connected on the ECU. Cam 1 is always used for the Intake cam or Cyl1 bank cam.

Cam2

In this block the output will be on between 1900 and 4200 RPM if the TPS value is above 20% as above. This block is made visible to indicate which driver is used. This is for a dual cam setup on a V8. For a 4 Cyl with 2 cams the settings will be active and independent. The driver output will indicate where the solenoid must be connected on the ECU. Cam 2 is always used for the Exhaust cam or other bank than Cyl1 position.

The intake flap

This block is firmware dependent on control according to requirements. For Toyota V8 the flap will be powered or activated whenever the RPM's are between 2500 and 4900 in this sample regardless of throttle position. It will also be powered if the throttle is less than 60% depressed regardless of RPM. Said in another way, the flap will not be powered at over 60% throttle and at lower than 2500 RPM or higher than 4900 RPM.


Flat Shift

Help > Galaxy Sotware Ver 3.5 > ECU Settings > Turbo Settings >

P3_M5_D Ver 3.5

Flat Shift

This feature will momentarily cut the fuel or spark or both for a pre-set time during shifting. This will slow the engine RPM momentarily to ease shifting process in the gearbox. It is initiated by a negative going transition pulse of a switch, or electronics or load cell that will give an earth contact. The switch is combined with movement of the gear lever.

Settings

The following settings is done to activate this feature. On the Mercury the same input for dual map is used. This input is normally only used at start-up of the ECU. It is then used as flat shift input during run conditions. Normally an open switch will mean Map 1 when the ECU start. Then if this contact is earthed the flat shift delay will be activated. If you want to start in Map 2 hold the switch in and put the ignition on. Then Map 2 is implemented, from there on the flat shift work as normal.

Choose a signal for the Dual Map and Flat shift. Note that Altitude requires a 1K pull-up resistor to 5 volt.

Note that the correct wiring for the dual map switch must be followed.

A delay can be adjusted from 0 to 350 milliseconds. Zero will deactivate the feature.

You may select the type of engine cut which is the same as the normal rev limiter settings. Soft will cut only fuel, Hard will cut fuel and spark and Spark only speak for itself.


Galaxy Communication Problems

Help > Startup Procedure & FAQ > Frequently asked questions >

Galaxy_Device_Settings Ver 3.5

Device Settings

This software uses standard Windows protocol. Unfortunately there are a few settings to ensure that the software and device communicate properly in the Windows environment. The latest Galaxy software can work in all versions from XP to windows 10. Under the section 'Tuning software' on Spitronics website is an extensive manual. This is just a guide to the most important settings to get started quickly.

Click on Galaxy and Settings.

If you prefer using the Galaxy assistant, check this box. It will automatically begin in this setting thereafter.

Windows may run other programs with more priority in the background making communication erratic and slow. Check this box to ensure Windows gives Galaxy priority.

Set this mode to expert to enable all settings.

Make sure the saved file location is set as above. Alternatively click on the folder and guide it to this location. Temporary files etc. are saved in this location. The 2 settings above ensures Galaxy saves every 10 minutes the map as is at that specific time. This is handy, should anything occur, you can refer back to a previous map that was working.

Set Baud and com port as above.

Some programs may try to use the USB comport and create conflict with communication to the device. Check this box to lock the port exclusively.

Set the Sleep intervals as above. Should the Communication LED on galaxy flash red or slowly, increase the poll interval.


Error Codes

Help > Galaxy Sotware Ver 3.5 >

ECU_ErrorCodes_Ver 3.5

ECU Error Codes

The ECU software has Error, Warning and Information codes displayed in the information tool bar at the bottom of the screen. These codes will help the tuner to find problems during startup procedures and tuning. They also assist to check if the ECU is functioning correctly. Sometimes one of these functions will cut the fuel and the tuner can then easily identify which one.

These codes are selected on the code list. To check that they are on click on [image] then these 3 must be green. The Error Code cannot be switched off in the code list.

The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once until it disappears and when it reappears the code will be logged again. This is to prevent the list from being too long. This however does not apply to the trigger error codes. They will make the counter add as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see if the code is continuous or was only listed once.

Note: when you crank an engine and it does not start there will be one error code 1 for missing teeth. This is normal and not an error. The ECU was expecting more trigger pulses but was stopped. (A tip)- Press C then crank the engine. There should be no error and 200 RPM until the key is released.

The blue codes are errors codes- This is normally around the trigger signals that make the ECU operate correctly. The red codes are warnings, like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing teeth - the crank sensor senses too few teeth per revolution

2 - Too many teeth - the crank sensor senses too many teeth per revolution

3 - Incorrect pick-up wiring - the crank sensors' trigger edge needs to be swopped or the wires must be swopped

4 - Missing TDC pulse - the TDC pulse is not present

5 - Missing home pulse - the Home pulse is not present

6 - Not Defined

7 - Fuel Safety Cut-out - the fuel pressure sensors' low limit has been reached

8 - Economy Fuel Cut - the downhill economy fuel cut has been implemented

9 - Rev Limiter - the engine rev limit has been exceeded

10 - Boost Limiter - the boost pressure limit has been exceeded

11 - Water Temperature Limiter - the water temperature limit has been exceeded

12 - Launch Limiter - the launch limit RPM has been exceeded

13 - Lambda Control Limit - the lambda control limit has been reached

14 - Battery Voltage Low Limit - when the battery voltage falls below a critical limit

15 - Not used

16 - Flat Shift - when flat shift has been activated

17 - Flood control - when flat shift has been activated


Specific Instructions

Help > Galaxy Sotware Ver 3.5 >

Software Ver 3.5

This chapter assists in understanding the tuning software. It is written in the same order as is found in the software, to ease with finding the right information. Note that some tuning blocks refer to the same feature so information will go to the same page. This will be less confusing to find the right information.

See the sub folders for explanation on the software.


Rotary Engines

Help > Galaxy Sotware Ver 3.5 > Specific Instructions >

Rotary Special instructions.

General Information

Now the two stroke setting means that the firmware will inject the calculated amount of injector time in every stroke. Putting it off means that the injector time will be divided by 2. This will cause the tuning graphs to be twice as high. The advantage is that the graphs tune more easily and adjustments is 50% finer resolution. A drawback is that 25 milliseconds maximum fueling is easily reached during accelerator pump function and my cause problems at tuning flat spots during blip conditions.

Another feature is the duel injector system. It can be tuned with a ratio adjustment or separate graph system which is discussed in this article. Not that the secondary injectors is compensated on all the graphs except the lambda control. Also during cranking the secondary's is not pulsed. During acceleration they will be pulsed even if the main graph is set at zero.

Determining if coils is on the correct plugs.

Due to the duel spark plug system it is sometimes confusing to understand why some leads can be faulty. The rotary engine allow the leading plugs to be fired in wasted spark configuration. The reason is that the non-combustion rotor is still covering the leading plug with the previous chamber. The trailing plug however is now situated in the upcoming chamber and will ignite the fuel in the intake should it be fired with the other rotor. Spitronics use a different setup for the 3 coil wasted spark Leading coil pack. You connect both leading drivers on to the same wasted spark coil. Then it is Important to set the software to wasted spark as the firmware will then reduce charge time at high RPM to ensure that charge time do not overlap and that there is enough discharge time between charges. See the setting below.

NOTE:Always use a colder spark plug on the trailing and one size warmer on the leading for instance NGK B10EG on trailing and NGK B9EG on the leading. This will help with detonation that can be caused by a warmer plug on the trailing do to heat glow on the intake cycle

Note that should the "Wasted spark coil per cylinder" be selected then the software will change it to Full Sequential.

Now to make sure that coils is setup in the right position, disconnect the drivers from the trailing coils. It is not good practice to pull off HT leads and let them spark in dry air. Reason is high voltage feedback may damage coil drivers. Now start the engine. There may be a 5% power loss but it should start easy and rev up smoothly. Get the timing light out and make sure timing is according to specs. Now disconnect the leading coils and reconnect the trailing coils. In the software set the maximum trailing degrees to zero as below. This will ensure that the trailing degrees fire the same time as the leading plugs. Now insert the trailing plugs onto their plugs. Again start the engine. If they are correct then the engine should start and rev up smoothly. There should be a power difference but no misfires. If they are incorrect there should be misfires in the intake manifold. Swop them around and try again.

Timing light degrees.

Note that due to 1 spark per revolution the normal timing lights that does not have a 2 stroke setting will have an error in its reading. The degrees on the timing light will be double to actual degrees. If the timing light is on 20 it is 10 actual. If you use the wasted spark option there is 2 pulses per revolution and the degrees will be quadruple on the timing light. If the timing light is on 40 it is 10 actual. Best way in these conditions is set the timing light to zero degrees and work on the degrees on the engine pulley.

Determine Maximum injector time.

This is important because at high revs there is only a certain amount of time to inject fuel. This time may not be exceeded as the engine will lean out. You may argue but at lower RPM's you can go higher duty cycle with the primaries but the problem is that this is not matrix and the switch over point is hard to determine. This time is calculated as follows.

Injection Time = 85% * 60 / Max RPM

= 51 / 8000

= 0.006375

Or 6.375 milliseconds

85% is recommended max duty cycle of an injector.

Max in this example is 8000 RPM

First set all the RPM graphs to 0.

To tune this unit set the Micro fuel setting on graph. Now there is 2 graphs available for the dual injectors. Red is for primaries and blue is for secondary's. First adjust the secondary's to 0 right through the scale. Then at 3000 RPM adjust the primaries from light load to full load until the max time is reached. In this case 6.3 milliseconds. Make a note of the load where max injector time is reached. About 0.84 bar. Then make the rest of the graph flat at the same value.

Now take a load just smaller than max like 0.75 bar. Now look at the air fuel ratio. Lift the secondary's graph in totals till you see that the A/F ratio becomes richer. Decrease just enough till it is back to what it was. This offset will eliminate the dead band of the secondary injectors which will help to make the transition as smooth as possible.

Now you may increase the load and tune the secondary injectors to maintain the correct A/F ratio. Note that the secondary's may also not increase the max injection time.

Lastly taper the injection time to the left off to eliminate pulse on the secondary injectors. note the taper off is on the left where the primaries stopped working.


4+2Home 4Cyl Engines

Help > Galaxy Sotware Ver 3.5 > Specific Instructions >

4 Pulse + 2 Home Programs

Spitronics has a generic program for 3 different variations of this type of program. Mostly they are distributor hall type sensors. In the past we named the firmware according to the car manufacturer but then it made for confusion.

This firmware will be called Mercury2 ECU Combo 48 4+2Home Ver 3.5 30_11_2016.HEX

Now this firmware are used for different manufacturers like Mitsubishi, Mazda and Hyundai etc. It is up to the tuner to set it up so that coil and injection timing is correct. Or a map from a previous install will ease this process. Note that distributors can be turned but it is not advisable as it will create incorrect rotor fazing. Always leave the distributor in the manufacture position.

Timing Pulse

This is the yellow pulse in the pictures below. It is used to calculate the engine degrees for spark and fuel. There is an even 4 window signal in the distributor that gives 2 pulses per RPM which is 180° spaced apart. If the sensor is on the crank it will only have 2 teeth. The different versions may differ in length of the pulses but they are consistent in degree spacing on the rising and falling edge.

Home pulse

This is the yellow pulse in the pictures below. It is used to calculate TDC and Home signal. TDC will indicate to the ECU when Cylinder 1 is on TDC. This is adequate for Spilt-sequential injection and wasted spark. The Home signal will indicate when Cylinder 1 is on firing stroke. This is important to synchronize injection timing on a specific stroke for full sequential injection.

Setting up Instructions

Make sure the distributor is in the factory position. Otherwise do rotor phasing as discussed in the manual. Disconnect all the output connectors and leave only P1 connected. This is important as wrong settings will fire coil times at random degrees causing starter failure. Make sure the jumper settings are set up for Hall sensors.

Crank the engine and look at the errors on the software. If there are error 4 [image] then change the Trigger edge on the software [image] to the other side.

If there are error 5 [image] then change the TDC edge on the software [image] to the other side.

You can press ''C'' to clear the error. There should be no error during cranking then the ECU is happy with the setup.

Now the ECU can read your trigger pattern right but it still need to know where TDC and Home pulse are.

TDC is important for the coils so we start there. You can now connect P2. On Pluto2 and Saturn it is only the TDC that are required as they cannot do full sequential. Disconnect the injectors and fuel pump so that there is no fuel while we work with the timing light and spark degrees.

If you use 1 coil on the engine put the settings as below.

Gear teeth is adjustable 1 or 2 which will shift the timing 180° but it is irrelevant with a distributor.

Set the Maximum timing to 10 degrees so that it is easy to find the timing mark.

Now put a timing light on cylinder 1 and set the timing on it to be 0°. This will eliminate the timing errors for the setup procedure.

Now crank the engine and look at the timing mark on the pulley. If it is not around 10° BTDC adjust it in 10 degree steps to find it and het it close to 10. You can click the arrow to increase while someone is watching with the timing light.

If you cannot find it on the coil packs then it means it is 180° out of phase. Then set the [image] to 2 and start with timing sensor at 0 again. Repeat the above process. Once you find it then you can connect the other coils as per drawing.

Below is the settings for wasted spark or coil on plug COP. Notice that multi coil is also fired in wasted spark sequence. There are no performance difference.

After this adjustment put the Maximum timing back to the original value.

Timing for fuel can be adjusted in 360 steps. This is to change the phase of injection between the 2 revolutions. Unfortunately only gear programs can adjust different degrees on one revolution. There is no easy way to tell if you are on the right resolution but a dyno will indicate which one gives the better performance. This is usually found at low rpm loads. The setting to jump between the revolutions is [image]. It may be adjusted between 1 and 2.


Lexus V8 1UZ-FE vvti

Help > Galaxy Sotware Ver 3.5 > Specific Instructions >

Program 62 Lexus V8 1UZ-FE VVTI Special instructions Ver 3.5

The intake flap

It is controlled by firmware according to these settings in the software. This is done according to the Toyota manual for the V8. It may differ until other info is obtained this is how it works. The flap will be powered or activated whenever the RPM's are between 2500 and 4900 in this sample regardless of throttle position. It will also be powered if the throttle is less than 60% depressed regardless of RPM. Said in another way, the flap will not be powered at over 60% throttle and at lower than 2500 RPM or higher than 4900 RPM. This output is on GP2 driver and gives a ground signal. The other end is connected to 12 volt relay power. The GP2 settings will be disabled as these settings is now used.

The VVTI Cams

The intake cams is advanced when the RPM's is within the low and high limit of CAM 1 settings and the throttle is pressed more than the V-Tech TPS value. Said in another way, the intake cams is in retarded position whenever the throttle is pressed less than the V-Tech TPS value, or the RPM's is outside the low and high limit of CAM 1 settings. Positive 6 and 5 drivers are used to control the cams with duty cycle. For now it is used in open loop control and is either in fully advanced or fully retarded position. The cam sensors are wired in for loop control and firmware to control it is under development.


Memory Handling

Help > Galaxy Sotware Ver 3.5 >

Memory Handling in Ver 3.5

The Memory handling of Ver. 3.5 is different from the older systems. The reason is to let the ECU use the unused Coil and Injector drivers for GP outputs. The danger before was that if a customer loads a different Map file, the setup changes the output configuration of his device and that may damage his engine or the ECU.

Below is a block diagram of the map memory and how it is handled.

The memory is divided into 3 categories. (See description below):

Critical I/O setup data

The settings that will alter the inputs and outputs of the device are saved in this block. This memory however will never be overwritten by loading a map. The only way to make changes is to be online with the device and change the settings in the galaxy tuning software and then save them in the device. The advantage is that once the customer decides on his outputs it will stay like that and there is no risk of damaging his engine or ECU. Note: However, if you want to test this ECU on another vehicle you need to go into the device and change those settings before you start that engine. There is a way to load those settings with a map by Cloning, which is discussed further in the manual.

The settings saved in this block are:

This setting does not alter I/O but influences critical tuning data.

After this setting is checked a Map with Setup is automatically saved. Unchecked then only the Map graph and matrix data will be saved.

This setting changes the input which is used for the dual map feature on Mercury2. This setting was already saved permanently in the previous versions.

This setting determines how the RPM output is setup on the vehicle.

This setting is critical because it could free up drivers that may be used for GP outputs.

This setting is only used in Pluto2 and Saturn and is critical because it will damage coil or drivers if not set correctly.

This setting is critical because it could free up drivers that may be used for GP outputs.

This setting alters the I/O of the device

This setting alters the I/O of the device

This setting alters the I/O of the device

Map Setup Data

In this block all the other settings are saved. Note that there are still values like TPS calibration that are not interchangeable by different engines of the same model. If you don't want to save them just uncheck the Save Data setting.

Map Graph and matrix data

Only the graphs and matrix data is saved in this here. This then influences the actual tuning of individual engines.

Cloning

Cloning is copying a device exactly on the same model ECU. This is handy for builders with the same engines and drivetrains. If you want to save all the settings including the critical setup data, then it has to be loading in with other firmware. (See below)

1. Save the Map of the device you want to clone on your hard disk. No matter what the settings in the ECU is, all the data in all 3 blocks is saved during Map save.

2. Load the test program firmware for that device with the USB debug adapter. Note that there is a Customer test program that will not put outputs on and off which will open or charge the coils.

3. Connect the new device and open Galaxy only. Now load that map into Galaxy.

4. Click on connect and select download to device.

5. Load the final firmware back into the device. The map settings are now cloned.


Device Activation

Help > Galaxy Sotware Ver 3.5 >

ECU_Activate_0 Ver 3.5

Device Activation

One of the unique features of the Spitronics Engine Management device is the Internet activation procedure. This gives a dealer the opportunity to carry stock at a low price and activate it when required. . The dealers' customer may want to upgrade his device to a higher class for a different application. Once the internet side and payment is sorted with the dealer, the device must be activated. The balance is paid before activation which protects the dealer as well as the supplier.

Connect only P1 on the ECU. Connect the Laptop with Internet connection to the ECU and switch the power on. Do not crank the engine.

Open the Galaxy software only.

Click on the Plugins field on the top menus.

Click on Device classification button. The Detail screen of that device will be displayed. Note that the Hardware class is Not initialized and Program restriction is 255. The device must have final firmware in to be classified. In some cases it may still have the test program in. In this case the assign button will not be active.

Press the Assign button

Activation done on the internet( See screen example below), 'success' message will display. Note: This is now hardware classed as' Advance' or one of the classes requested then Program restriction is 0.

Click on Close. The device is now activated. Make sure that the firmware is correct for your application and load a relevant Tuning Map. Go through the startup procedure as normal.


Startup Procedure & FAQ

Help >

ECU_Startup_0 Ver 3.5

Startup Procedure

The startup procedure is very important. This is a universal ECU that can cater for many of engine types, and /or combinations. Setting values here may damage the ECU or some of the engine components permanently! The Maps supplied by the agents are solely supplied as a guideline and not guaranteed to be set up correctly for your application. It is your responsibility to make sure setup is done correctly!

Common failures include short circuited wires in the installation process, coil drivers set incorrectly for internal or external coils resulting in damaged coils or ECUs', injectors exposed to open air conditions causing fuel to flood cylinders and resulting in bent connecting rods, too larger fuses used resulting in damaged electrical components.

See the sub folders for explanations.


Preperation

Help > Startup Procedure & FAQ >

ECU_Startup_A Ver 3.5

Engine and system preparation.

Before connecting the ECU check the following:

1. Install new spark plugs on engines that were stored or stood a long time.

2. Service and test the injectors to ensure they all have the same fuel delivery and that the filters on them are clean.

3. First ensure that the installation is correct according to the Hardware Installation manual.

4. Test the electrical wiring using a multi meter as per the Installation Testing Procedure.

5. Power up the fuel pump by loosening the fuel pump positive from the relay circuit and connecting it to 12V battery positive. Check that the fuel pressure is around 3.5Bar and check for fuel leaks. Reconnect to the relay.


Step by Step Starup Procedure

Help > Startup Procedure & FAQ >

ECU_Startup_B Ver 3.5

Connecting the ECU for the first time

Now you can proceed with the following steps. If any steps do not correlate with the ECU operation, stop and look for the faults. Ensure that the ECU is earthed!!! Notice that there may be steps not applicable to certain ECU's. Then you may skip them.

1. Remove all the fuses. If it is an easy install harness with a common fuse on the main lead then disconnect the coils, injectors, fuel pump etc. from the power relay.

2. Ensure that the Jumper Settings are correct for that ECU.

3. Connect only the input connector P1 leaving the output connectors open. Switch the Ignition on. Do not start the engine! The yellow LED on the ECU must come on. Then, the blue LED on the idle stepper control unit must come on. (If it is installed). If the yellow LED does not come on switch the ECU off immediately as there may be a short on the 5 Volt output that will in time damage the ECU.

Then, with Pluto2 and Saturn the green LED will also come on and switch off. This will indicate that the ECU has a legal program loaded and the processor is running. Note that on Mercury2 the other 4 LEDS' are connected to drivers and does not come on with trigger signals.

4 Switch the Ignition off and connect the Laptop with the USB cable to the unit. Then, switch the ignition on, start the PC software and connect to the ECU. The engine data like the water and air temperature sensor should be displayed. It should read more or less correctly for the cold engine.

5. Go through the setup pages one by one and ensure that all the settings are correct for this engine. Especially the Trigger Level Output on Pluto2 and Saturn. This setting may damage the ECU or coils if set incorrectly!!! (Not applicable to Mercury2)

6. Ensure that the trigger sensors from the distributor or crank are set up correctly. Included in this their Trigger Level selection must be leading or trailing edge.

7. Check the Rotors' Fazing if you have a distributor system. This will make electrical interference on the ECU and Laptop if it is set incorrectly.

8. Calibrate the TPS and Map sensors and save the calibration as described under active sensors.

9. Set the maximum RPM range and Map sensor type and range.

10. The Map sensor value should be reading the atmospheric pressure of your region. (Check the Altitude chart for the correct pressure in your area.)

11. Make sure the Test function next to the trigger is turned on.

12. You may now crank the engine without the other connectors. Check that the Green LED flashes on Pluto2 and Saturn. Also look at the RPM signal on the timing map, it should show 200 to 300 rpm consistently. If it shows an erratic reading and running wild, do not proceed. First find the fault. It must be constant. The vacuum bar should move slightly to the left of the graph while cranking at closed throttle.

13. Look if any error code is displayed at the bottom. If there are errors, remedy the fault condition. Make sure the error/s are on in the software under the error list. To check click on [image] then these 3 must be green.

14. Save [image] the data to the ECU if it has been changed.

15. Switch the ignition off and connect the other connectors.

16. Remove all the fuses. If it is an easy install harness disconnect the power on the injectors, coils fuel pump, etc. Switch the ignition on. The relays will come on for three seconds then switch off again. If not, check the relay wire according to the drawing. If you have electronic relays, check the LED on them must come on.

17. Switch the ignition off and insert the fuel pump fuse. Start with 5A. If it blows check the wiring and try 7.5A as some pumps draw more power than others. Do not go to larger amp fuses as there may short somewhere!

18. Switch the ignition on, the fuel pump must start for three seconds and switch off.

19. Switch the ignition off and insert the coil fuses of 5A. If it blows check the wiring.

20. Now crank the engine with a timing light and check if the spark timing is in the 10°BTDC region. If not, check the Timing Chapter for the correct setup. Do not attempt to start if the timing is not right or if it is erratic. You may need to loosen the plug wire and make a small gap so that the timing light picks up the pulse of the spark plug. For coils that are bolted onto the plug, try using the trigger wire from the ECU. If this does not work, take a separate wire and wined it around three times over the inductive pickup of the timing light and then insert this wire between the trigger wire and the coil input. This will amplify the signal three times so that it will trigger the timing light. Set the timing light to zero timing, as wasted spark systems read double the degrees. This means if the timing light is adjusted to 20 degrees it is actually 10 degrees timing on the engine.

21. Switch the ignition off and insert the injector fuses of 5A. If it blows check the wiring.

22. Crank the engine. It should start. If the engine backfires or misses, stop and do some checks. (See the Faultfinding chapter. - Use the symptoms to find the fault in the fault finding guide.)

23. If your setup is correct the engine should start and idle smoothly.

24. Make sure the rpms' are constant before revving the engine. If it jumps more than 300 rpm intervals, recheck the trigger polarity. It must be steady.

25. Look at the exhaust. If there is black smoke, it is very rich. Try' leaning it out' on the water temp. graph by lowering the dot on the right side of the yellow bar.

26. Once the engine idles calibrate the timing so that the Timing value on the software and the timing light is on the same value.

27. During the heating up faze, blip the accelerator from time to time. If the engine has a flat spot it may be lean and need some more fuel. Adjust the Fuel Graph Manifold Pressure till the flat spot reduces.

28. The blue LED in the idle control should go off once the target RPM is reached. If it keeps on flashing then the ECU is trying to control the idling but nothing happens. It means the fault is on the idle and on the motors' side. Maybe a wiring fault or sticky stepper motor. It may also be a blocked airway or the throttle, opening is too large. Remember for every 15% of enrichment on the water correction graph, the ECU will raise the set RPM's by 100.

29. As the engine heats up, the water sensor value must increase. Adjust the mixture on the water graph or by lowering the Fuel Graph Manifold Pressure till the engine is at normal temperature.

30. The water graph should now be around 85°C with no fuel enrichment. If it is not, you can calibrate the sensor slightly on the setup page. The engine should rev up smoothly. If it has a flat spot it requires more fuel. Increase the Fuel Graph Manifold Pressure slightly till the flat spot is nearly gone.

Check that the timing is not the result of the flat spot. Check with the timing light that the timing increases as the software indicates.

31. Let the engine idle and adjust the Fuel Graph Manifold Pressure till it idles smoothly. Always try to make the mixture as lean as possible because it is difficult to feel when it is too rich.

32. Save [image] the data to the ECU. Save a copy to the Laptop at this stage as well. The car may stutter and die. Restart again and proceed with tuning.


Fault Finding

Faults and Remedies

The ECU yellow LED does not come on

  1. The ignition wire does not have 12Volt
  2. There is a short on the 5 Volt output from the ECU. The magnetic crank or distributor sensor, TPS and MAP sensor all use this 5 volt. ( Check the wiring.)

The Software does not connect to the ECU with the USB Converter

  1. Ensure that the yellow led on the ECU is on. Check the cables that they are correctly inserted.
  2. No Driver for this Device installed - The USB converter must have a driver CD which has to be installed first.
  3. Faulty device settings in the Galaxy software.
  4. Faulty USB converter.
  5. Faulty ECU.

The engine does not start for the first time

  1. Check for error codes. This is always the first place to look and a good indication of the problem. Ensure that all the codes are ''On''.
  2. Go through the Startup Procedure to ensure ECUs' operation is correct.
  3. If you crank the engine and it does not want to start, disconnect the high tension leads at the spark plugs one by one and check for spark on the plugs. Use another spark plug in the lead and hold the earth onto the engine.- If still no spark:

a. Check on the laptop and see if there are no errors. Make sure there is 200 rpm while cranking. If not, check the crank or distributor signals. Gaps of magnetic pickups may be too large.

b. Check if sensor polarity is correct.

c. Check if the fuel and Coil relays pull-in at ignition on. If not, check that the numbers on the relays are correctly wired. Electronic relays have a LED that will come on at Ignition on.

d. Test if the coils have positive supply +12 Volt when cranking the engine.

e. Test the coil resistance from the relevant connecter to see if there is an open circuit.

f. Test the coil to see if faulty.

g. If distributor type, check the spark at the coil HT pole.

  4. If there is spark, take out one of the spark plugs. If it is dry it means there is no fuel. Check for:

a. Check on the laptop and see if there are no errors.

b. Look at the injector milliseconds bar, it should indicate that the ECU is injecting fuel at around 10 milliseconds during cranking.

c. Ensure the fuel pump is running during cranking. If you switch ignition on it should pump for 3 seconds.

d. If it shows zero milliseconds, check the map calibration, TPS calibration, fuel cut off function settings. There should be an error code helping you to identify which control program prevent the injectors from pulsing.

e. Test the fuel pressure by loosening a bolt on the fuel rail somewhere. Hold a rag over the joint to prevent spillage.( Keep a fire extinguisher close by!)

f. Ensure that the injectors were checked and serviced if the engine stood for a long time.

g. Put your fingers on the injectors and feel if they pulse during cranking.

  5. If the plugs are wet it means there is fuel. (Check the following):

a. It may be that the start fueling was excessive and the plugs were flooded. Dry them and try again. You may also push the throttle in completely and crank the engine till it starts or the plugs becomes dry.

b. It may be that the ignition timing is setup incorrectly. Then firing occurs at the wrong time and failing to ignite the fuel mixture. Check the timing setup again for the specific engine.

c. The plugs may be old or dead. (Replace.)

  6. If the engine tends to stop cranking suddenly. (Check the following):

a. It may be that the timing is too fast. Reduce timing by 10 degrees. Add more teeth if a crank gear is used.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

Engine backfires during cranking

  1. Check for error codes. This is always the first place to look and a good indication of the problem.

  2. The engine backfires through the intake.

a. Faulty ignition timing or firing order. Check the timing setup for the specific engine again.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

d. Check if the RPM bar jumps erratically in the PC software. If it does, the gap of the magnetic sensors may be too large or the signal too weak or interference from the ignition coils.

e. If it has a distributor, check rotor phasing and that it is on the correct cylinder at TDC.

  3. The engine backfires through the exhaust.

a. Too lean fuel mixture. Increase by 10 at a time on the fuel ratio adjuster.

b. Water temperature sensor or compensation map could be incorrect.

c. Some of the plugs may be old or dead. (Replace.)

Engine starts but stalls directly after starting

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check the map sensor in the fuel map field is operational. The red bar should be on altitude pressure value. If not, it may be a calibrating error or faulty wiring.
  3. The fuel mixture may be too lean. Try to enrich using the fuel ratio adjuster.
  4. The temperature sensor may be faulty causing the cold engine to give a warm signal to the ECU. Thus thinning the mixture out.
  5. Incorrect Fuel Cutoff settings. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. Incorrect Engine Limiter settings

Engine starts but is very rich

  1. Check the map sensor in the fuel map field is operational. The red bar should be on altitude pressure value. If not, it may be a calibration error or faulty wiring.
  2. The fuel ratio adjuster is set too high. Start with 100%.
  3. Check if the water temp. sensor is working. If not, it will keep on enriching the mix as if for a cold engine.
  4. Some of the plugs may be dead, and then the engine loses manifold vacuum, as a result other cylinders are enriched.
  5. Fuel maps tuned too high.( Lower the values.)
  6. Fuel pressure regulator regulates too high. Measure the pressure. It should be between 2.5 and 3.5 bar.

RPM signals very erratic.

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Incorrect magnetic trigger polarity.
  3. Interference on pickup. ( See Precautions)

Engine starts but does not rev- up

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check that the map sensor in the fuel map field is operating and calibrated. The red bar should move to the right if the throttle is pressed.
  3. Too lean mixture. Try increasing the main jet value.
  4. Rev limiter is set too low.
  5. Check the micro fueling and boost limiter blocks and see if the settings there are correct. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. The Fuel Cut-Off settings are wrong.
  7. Incorrect rotor fazing or timing. (Check with a timing light.)
  8. The magnetic crank or distributor sensors' negative and positive wires are changed around. The gap may be too large.
  9. Fuel pressure or flow rate is too low. Dirty fuel filter.
  10. Faulty fuel pump.

Idle control does not work

  1. Check if the wiring is correct as indicated on the drawing. If it is an idle valve, make sure the diode is intact. If it is a stepper controller, make sure the sequence is wired correctly. (It may try to close instead of open.)
  2. Faulty TPS setting. Make sure the TPS is calibrated correctly. It must go from 0 to 100% over the full range.
  3. Check the idle control settings according to the idle control explanation.
  4. Make sure that the throttle position is set correctly at idling. The idle valve can only close as much as this setting.
  5. Check if the idle valve or stepper motor is not stuck. The idle valve can be pulsed with 12Volt to see if it opens and the stepper normally vibrates when the ignition is switched on. It may still be stuck even if it vibrates. (So take the stepper off and see if it opens.)
  6. If the blue LED on the stepper idle controller is constantly on during idle, it means that the idle computer does not receive the RPM pulse from the ECU. (Re-check the wiring.)
  7. If the blue LED on the idle controller flashes, it means that the idle computer tries to adjust the RPM but nothing happened. The idle motor itself is sticky or wired incorrectly. Open it up and clean and lubricate. (With the lengthily transportation on ships it corrodes on the inside.) The wiring to the idle motor may be incorrect. The airway of the idle motor is blocked.

The automatic transmission does not shift

  1. Connect to the TCU and see if the TPS and RPM signals are present. If not, ensure the correct wiring between the TCU and UCU are correct.
  2. See the relevant TCU manual for information.

Spark plugs do not last

  1. Fuel mixture too rich.
  2. Wrong temperature plugs.
  3. Charge time too long. Reduce the time.

Flat spot when accelerating

  1. Another vacuum line tied into the Map sensor line.
  2. Restricted vacuum line.
  3. Vacuum line too long.
  4. Too small port for Map sensor on intake manifold.
  5. Incorrect fuel setting of maps or accelerator pump.

Engine lacks power, idle erratic, or runs lean

  1. The fuel pressure is erratic. This may be due to the pump sucking air on the in feed which causes cavitation and loss of pressure. This happens more frequent when the engine is hot.
  2. Positive injector is wired incorrectly. It does not have its' own supply direct from the battery via relay 1.
  3. Incorrect setting of fuel maps.
  4. Fuel pressure or flow rate to low. Dirty fuel filter.
  5. Faulty fuel pump.

ECU cuts and start erratic or randomly during driving - (See Electrical Interference)

Copyright © 2013. All rights reserved.


Frequently asked questions

Help > Startup Procedure & FAQ >

FAQ Frequently Asked Questions

This chapter will shed light on certain areas where common mistakes are made or errors can be found. It is a general knowledge chapter and will have all the questions answered around the topic. It is systematically put forward and will guide you to the problem or to a point where the dealer can help you faster and not need to ask un necessary questions. If your answer is not there please contact the dealer for help and let us know to answer that question for future use as well.


Questions on Training Courses

Help > Startup Procedure & FAQ > Frequently asked questions >

Questions on Training course

When is the next course?

Courses are regularly held by Spitronics wholesalers. There are 3 of them in South Africa. It is best to look at their websites and query the questions directly to them. Look on our website www.spitronics.com under local support to see their details. We may from time to time post dates on top of our site.

How long is the course?

A course is normally 2 day but it depends on the trainer what he wants to cover in training.

Where is the course?

The wholesalers is situated in Pretoria, Johannesburg and George. They cover different regions and look after customers there.

What does the course consist of?

There is usually a basic course and advance course. The basic is aimed at new customers to the product and the course will teach the student everything in the manual and what is the aim of the settings. Also different wiring method of the products.

The advance is aimed at regular customers and customers with dyno facilities and course will go into deeper detail on tuning and setup of advance racing features.

What is the alternative to the training course to get started with the Spitronics products.

Our products are developed as DIY and are well documented in our manuals. We also provide the software for the customer to load onto his system and play offline even without a product. To get started we put a folder and file on the web www.spitronics.com under downloads called "Getting started with Spitronics". In there are all the links and descriptions to help guide you where all the manuals and software are located. Please feel free to download it and work through it. There is also a guide on how to install the Galaxy software.


Uninstall / Reinstall Galaxy Software

Help > Startup Procedure & FAQ > Frequently asked questions >

How to uninstall and re-install Galaxy software

Sometimes Windows crash and registry settings becomes corrupt. This will then prevent Galaxy from operating correctly and it would be necessary to clean the registry files.

Step 1

Uninstall Galaxy.

Go to control panel on windows. You can get this at the start menu.

Click on Programs and features.

Then click on Galaxy to highlight it

Then click on uninstall and follow the instructions.

Step 2

Go to www.spitronics.com

Click on Downloads

Then click on Tuning Software

Then click on Galaxy Ver 3

Then Download GalaxyCleaner.rar

Note if you don't have WinRAR then download a free version on top of that page by clicking on the link

Now un-compress the Galaxy cleaner file and Run it.

Click on Remove Galaxy and follow instructions

Step 3

Restart the computer. This is important to let windows reload the registry settings.

Step 4

Install Galaxy again.

Go to www.spitronics.com

Click on downloads

Then click on tuning software

Then click on Galaxy Ver 3

Then Download Galaxy Installer

Run the exe file and follow the instructions.


Testing Magnetic Crank sensor

Help > Startup Procedure & FAQ > Frequently asked questions >

Testing Magnetic Crank Triggers

Work through each point below to find your problem.

1. First ensure that the setup in galaxy is done according to the startup procedure. This means you will only have P1 connecter and on Mercury2 also P4. The other connecters must be open except the comms cable.

2. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information to verify.

3. Make sure the jumper settings is for magnetic sensor. On Pluto2 and Saturn it must be set to 5 volt position and the 2 pin jumper must be open. On Mercury2 the jumper must be open. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the real-time Volts bar does not fall too low. A healthy battery will crank at 11 volts and above. Below 9 volts the sensor signal becomes weak and fall below the voltage threshold of the specific ECU. If it falls below 10 see the chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault condition. Make sure that the errors is set on in the software under the error list. To check click on [image] then these 3 must be green.

6. Check that the Green LED flashes on Pluto2 and Saturn. Mercury2 does not flash on the green LED as it is connected to the RPM output driver. Also look at the RPM signal in the real-time display. It should show 200 to 300 rpm constant. If it shows erratic and run wild, do not proceed to start. It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU see them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

Testing the sensor.

1. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses are also tied to this point. We call this junction Test point A

2. Disconnect P1 from the ECU as well. Now use a multi meter and put it on 2000 ohms scale.

3. For Mercury2 Measure from Test point A to pin 12 on the P1 harness connecter. Pluto2 or Saturn is measured between pin 12 and 6. You should get a resistance of 300 to 2000 ohm depending on the sensor. If you swop the meter wires you must read the same ohm measurement. If you don't get a reading it means your sensor is not connected correctly. Check on your wiring connections. NB! Do not press too hard on the female pins as you may damage them resulting in poor contact later.

Harness Pin view

4. If you do get a reading put the meter on AC volts. And measure on the same points. Use the lowest scale or 20 volts. Now crank the engine. The sensor will generate AC volts. If it is Pluto2 or Saturn a voltage of more than 1 Volt is required for operation. Mercury2 requires a voltage above 0.5 volt. If this volts is lower it means the signal is too weak to be used. This could be due to a dirty sensor or the gap is too wide between the sensor and gear. The gap is normally below 1 mm. It could also be that the sensor magnet inside is wider than the teeth pitch if it is a custom installation.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting of the engine read the following points.

1. The ignitions coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU.

3. Errors that comes at higher RPM may be due to a trigger wheel that is not balanced or buckle. It could also be due to a small pitch of the gear teeth to a bigger sensor diameter.

4. Also ensure that the test signal next to the crank sensor is off.

5. The sensor signal could fade with RPM due to the gap between it and the trigger wheel too close or too far.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs is used for COP engines and non-resistor plugs for HT leads. Also ensure that you use carbon HT leads and not copper leads.


Power Connection

Help > Startup Procedure & FAQ > Frequently asked questions >

Power Connection

When an ECU does not have proper connections to Power or Earth it will generate spikes and erratic behavior. The starter and alternator needs to be wired correctly.

Earth straps can cause interference and is usually a problem during cranking. The starter draw around 60 amp during cranking. Its current flow is a thick strap from battery negative directly to the engine. Then form battery positive to the starter solenoid to the starter motor. You do not want to share these wires with sensitive electronics. The chassis also needs to be earthed. The best way is another earth strap from battery negative to the chassis. Do not earth the chassis and engine to each other to simplify wiring. This cause a common wire that will share the starter spikes and will cause interference. The Alternator is also a source of interference. It is best to connect the charge wire which is the thick one directly to the battery positive. Remember the battery acts as a damping source for interference. So it is best to connect all different supplies to the poles.

Testing for earth problems.

1. Make sure all earth points are properly earthed. Sometimes paint of the chassis will prevent a good electrical connection.

2. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses is also tied to this point. We call this junction Test point A

3. First ensure that the setup in galaxy is done according to the startup procedure. This means you will only have P1 connecter and on Mercury2 also P4. The other connecters must be open except the comms cable.

4. Now use a multi meter and put it on AC volts. Now measure on test point a to battery negative pole. Now crank the engine. The reading should be less than 0.2 volt. If it is higher it means a bad earth. See the advice above.

5. Now do the same test for the ECU positive. Measure between the ECU power pin 10 that comes from the key to battery positive terminal. Here you may find a slight more voltage due to other electronics that draw current from the ignition. Again if the volts is more that 1volt then you may need to put a relay in to bypass ignition key voltage drops. Remember the key does not supply much current and is only low amperage power to activate relays. Below is a circuit of a bypass relay.


Spark Problems

Help > Startup Procedure & FAQ > Frequently asked questions >

Spark Problems

Work through each point below to find your problem.

1. First ensure that the setup in galaxy is done according to the startup procedure. You came to a point where you want to start and everything is according to the startup procedure but there is no spark or weak spark. The timing bar should read around 10 degrees and there should be no errors.

2. Ensure that the coils are correctly powered from the ECU relay. Do not connect them from the original vehicle power. This may damage the coils during startup of the ECU.

3. Coils require a constant battery supply on their positive or supply terminal. This power is switched via a relay so that it is disconnected during an accident or power off condition. To check that this power is present put you multi-meter on DC volts at a scale of 20 or higher. Measure on battery negative pole and the coil positive terminal. Now switch the ignition on. The power relay will come on for 3 seconds then switch of. During this time you must read 12 volt on these points. If there is no volts or less than battery voltage check the wiring for bad connections. This is no load power testing.

4. If you have dumb coils (coils without drivers) do the same test as above but this time measure on coil negative. You should see 12 volt on this point too. If not it means the coil is dead or open circuit. Replace. Intelligent coils (coils with built in drivers) cannot be tested like this.

5. Sometimes open load will indicate that the power is present but during load conditions the power will drop due to high resistance that is formed by bad connections. So for load testing switch the meter to AC volts and measure at the same points as point 3 above. Crank the engine. During cranking there should be close to zero volts. If there are any volts above 2 it means that the power to the coils is fluctuating which could not happen because it is connected to the battery. This will indicate a bad connection in the power supply line during load conditions. Sometimes a bad fuse connection makes this voltage drop. With the same test procedure it could be tested backwards to the problem source. It could also be due to too thin supply wires that cannot hold the current that flows through them.

6. The next problem could be in the earth line of the coil current. Normally the driver supply earth to the coil momentarily to charge the coil and then break the earth connection to fire the coil. For dumb coils the earth is switched in the ECU or external coil driver. To test this put the meter on AC volts like above and measure between the ECU earth wire on the chassis or the external coil diver's earth. Again crank the engine and see if you measure any volts. It should be close to zero volts. Above 2 volts means a bad connection in the negative earth line during load conditions.

7. Now you have established that power and earth is present at the coil or driver but there is still no spark. This means that the trigger pulse is not coming from the ECU or driver. For dumb coils put the meter on the highest AC volts scale and measure on coil negative and battery negative. Crank the engine. You should read a voltage above 100 volts. This means the driver and primary coil works. If you put a sparkplug on the HT lead and let the plug earth against the engine you should be able to see the spark. If not then the coil secondary is dead or open circuit. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

8. For intelligent coils measure the trigger signal to the driver side. Here you should measure 12 volts meaning that the ECU driver is pulsing the coil. If no spark then the coil driver is dead. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

9. If you use an external driver and dumb coil then measure the trigger signal on the ECU side. Again it should be 12 volt during cranking. If not it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe. If there is a pulse measure the coil negative side for the hi-voltage pulse around 100 volt. Remember to put the meter on the higher voltage scale. If there is no pulse it means the driver is dead. Replace.

10. There may be 2 faults present. So finding one may only then present the other. Test from the beginning again.